aboutsummaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorJeffrey Stedfast <fejj@ximian.com>2002-07-31 09:00:10 +0800
committerJeffrey Stedfast <fejj@src.gnome.org>2002-07-31 09:00:10 +0800
commit1ea002e1b80173aa47254fe9371dbe66c7505cba (patch)
treebc8749d2c62da1746be222074988fc63a14ccd82 /configure.in
parentc7f08ebc3da4a874f3433e49ed409260305726e7 (diff)
downloadgsoc2013-evolution-1ea002e1b80173aa47254fe9371dbe66c7505cba.tar
gsoc2013-evolution-1ea002e1b80173aa47254fe9371dbe66c7505cba.tar.gz
gsoc2013-evolution-1ea002e1b80173aa47254fe9371dbe66c7505cba.tar.bz2
gsoc2013-evolution-1ea002e1b80173aa47254fe9371dbe66c7505cba.tar.lz
gsoc2013-evolution-1ea002e1b80173aa47254fe9371dbe66c7505cba.tar.xz
gsoc2013-evolution-1ea002e1b80173aa47254fe9371dbe66c7505cba.tar.zst
gsoc2013-evolution-1ea002e1b80173aa47254fe9371dbe66c7505cba.zip
Add checks for IPv6 support.
2002-07-22 Jeffrey Stedfast <fejj@ximian.com> * configure.in: Add checks for IPv6 support. svn path=/trunk/; revision=17649
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in38
1 files changed, 37 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index d809530fdb..2ae87ac430 100644
--- a/configure.in
+++ b/configure.in
@@ -167,7 +167,7 @@ AC_CACHE_CHECK([if ctime_r wants three arguments], ac_cv_ctime_r_three_args,
],[
char *buf;
time_t date;
- ctime_r( &date, buf, 100 );
+ ctime_r (&date, buf, 100);
],[
ac_cv_ctime_r_three_args=yes
],[
@@ -245,6 +245,41 @@ if test "x$ac_cv_gethostbyaddr_r_seven_args" = "xyes" ; then
AC_DEFINE(GETHOSTBYADDR_R_SEVEN_ARGS)
fi
+
+dnl **************************************************
+dnl * IPv6 support
+dnl **************************************************
+AC_ARG_ENABLE(ipv6, [ --enable-ipv6=[no/yes] Enable support for resolving IPv6 addresses.],,enable_ipv6=no)
+if test "x$enable_ipv6" = "xyes"; then
+AC_CACHE_CHECK([if system has necessary structs and functions for IPv6 support], msg_ipv6,
+[
+ AC_TRY_COMPILE([
+ #include "confdefs.h"
+ #include <sys/types.h>
+ #include <sys/socket.h>
+ #include <netinet/in.h>
+ #include <netdb.h>
+
+ ],[
+ struct addrinfo hints, *res;
+ struct sockaddr_in6 sin6;
+ int af = AF_INET6;
+
+ getaddrinfo ("www.ximian.com", NULL, &hints, &res);
+ freeaddrinfo (res);
+ ],[
+ msg_ipv6=yes
+ ],[
+ enable_ipv6=no
+ msg_ipv6=no
+ ])
+])
+else
+ msg_ipv6=no
+fi
+AM_CONDITIONAL(ENABLE_IPv6, test "x$enable_ipv6" = "xyes")
+
+
dnl ***********
dnl * db3 stuff
dnl ***********
@@ -1218,6 +1253,7 @@ echo "\
Pilot conduits: $msg_pilot
Kerberos 4/5: $msg_krb4/$msg_krb5
SSL support: $msg_ssl
+ IPv6 support: $msg_ipv6
Dot Locking: $msg_dot
File Locking: $msg_file
Gtk-doc: $enable_gtk_doc