aboutsummaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorNot Zed <NotZed@Ximian.com>2005-01-11 11:03:23 +0800
committerMichael Zucci <zucchi@src.gnome.org>2005-01-11 11:03:23 +0800
commit1b5ef38f5f2e71c3ea39b102b965dd0760c868e5 (patch)
tree4bb2c4a0da6934fc0cb24e86637f12eb30a1ad96 /configure.in
parentd521e9581b5ba2e88ba921c8e1b79d73cc35d4ef (diff)
downloadgsoc2013-evolution-1b5ef38f5f2e71c3ea39b102b965dd0760c868e5.tar
gsoc2013-evolution-1b5ef38f5f2e71c3ea39b102b965dd0760c868e5.tar.gz
gsoc2013-evolution-1b5ef38f5f2e71c3ea39b102b965dd0760c868e5.tar.bz2
gsoc2013-evolution-1b5ef38f5f2e71c3ea39b102b965dd0760c868e5.tar.lz
gsoc2013-evolution-1b5ef38f5f2e71c3ea39b102b965dd0760c868e5.tar.xz
gsoc2013-evolution-1b5ef38f5f2e71c3ea39b102b965dd0760c868e5.tar.zst
gsoc2013-evolution-1b5ef38f5f2e71c3ea39b102b965dd0760c868e5.zip
added new mail plugin & checks.
2005-01-11 Not Zed <NotZed@Ximian.com> * configure.in: added new mail plugin & checks. svn path=/trunk/; revision=28346
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in19
1 files changed, 17 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index 708c1704a3..a998f4b20c 100644
--- a/configure.in
+++ b/configure.in
@@ -1334,7 +1334,7 @@ AC_ARG_ENABLE(plugins, [ --enable-plugins=[no/all/list] Enable plugins.],e
dnl Add any new plugins here
plugins_base="calendar-file calendar-http calendar-weather groupwise-account-setup plugin-manager send-options shared-folder groupwise-send-options"
-plugins_all="bbdb subject-thread save-attachments prefer-plain save-calendar select-one-source copy-tool mail-to-meeting mail-to-task folder-unsubscribe mark-calendar-offline audio-inline mailing-list-actions groupwise-account-setup itip-formatter backup-restore send-options shared-folder groupwise-send-options exchange-account-setup"
+plugins_all="bbdb subject-thread save-attachments prefer-plain save-calendar select-one-source copy-tool mail-to-meeting mail-to-task folder-unsubscribe mark-calendar-offline audio-inline mailing-list-actions groupwise-account-setup itip-formatter backup-restore send-options shared-folder groupwise-send-options exchange-account-setup new-mail-notify"
case x"$enable_plugins" in
xno)
@@ -1370,11 +1370,25 @@ then
AC_SUBST(GSTREAMER_LIBS)
else
plugins_enabled=`echo $plugins_enabled | sed -e "s/audio-inline//g"`
- echo "warning: gstreamer was not found, audio-inline pluging will not be built."
+ echo "warning: gstreamer was not found, audio-inline plugin will not be built."
echo "you are probably missing gstreamer-devel package."
fi
fi
+if echo ${plugins_enabled} | grep -q "new-mail-notify" ; then
+ if ${PKG_CONFIG} --exists dbus-glib-1 ; then
+ dnl **************************************************
+ dnl * New Mail Notify plugin
+ dnl **************************************************
+ PKG_CHECK_MODULES(NMN, dbus-glib-1)
+ AC_SUBST(NMN_CFLAGS)
+ AC_SUBST(NMN_LIBS)
+ else
+ plugins_enabled=`echo $plugins_enabled | sed -e "s/new-mail-notify//g"`
+ echo "warning: dbus-glib-1 was not found, new-mail-notify plugin will not be built."
+ fi
+fi
+
##################################################
# Check for gtk-doc.
##################################################
@@ -1543,6 +1557,7 @@ plugins/bbdb/Makefile
plugins/audio-inline/Makefile
plugins/mail-to-meeting/Makefile
plugins/mail-to-task/Makefile
+plugins/new-mail-notify/Makefile
plugins/subject-thread/Makefile
plugins/save-attachments/Makefile
plugins/save-calendar/Makefile