aboutsummaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorTor Lillqvist <tml@novell.com>2008-06-06 19:19:17 +0800
committerTor Lillqvist <tml@src.gnome.org>2008-06-06 19:19:17 +0800
commit14a52517906af2994cd2059b4ef9f98139cb3980 (patch)
tree3744a1274c1302be27a7e6c810296974179c702a /configure.in
parent77a5d97f7092dc485a0c8d38343f7c5928caa97d (diff)
downloadgsoc2013-evolution-14a52517906af2994cd2059b4ef9f98139cb3980.tar
gsoc2013-evolution-14a52517906af2994cd2059b4ef9f98139cb3980.tar.gz
gsoc2013-evolution-14a52517906af2994cd2059b4ef9f98139cb3980.tar.bz2
gsoc2013-evolution-14a52517906af2994cd2059b4ef9f98139cb3980.tar.lz
gsoc2013-evolution-14a52517906af2994cd2059b4ef9f98139cb3980.tar.xz
gsoc2013-evolution-14a52517906af2994cd2059b4ef9f98139cb3980.tar.zst
gsoc2013-evolution-14a52517906af2994cd2059b4ef9f98139cb3980.zip
Add -Wl,--exclude-libs=libiconv.a to ICONV_LIBS on Windows to avoid
2008-06-06 Tor Lillqvist <tml@novell.com> * configure.in: Add -Wl,--exclude-libs=libiconv.a to ICONV_LIBS on Windows to avoid auto-exporting functions from the static libiconv.a implementation in win_iconv from evolution's DLLs. svn path=/trunk/; revision=35602
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in5
1 files changed, 5 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 45d4e19240..2e2ac2c43b 100644
--- a/configure.in
+++ b/configure.in
@@ -230,6 +230,11 @@ int main (int argc, char **argv)
if test $ac_cv_libiconv = yes; then
ICONV_LIBS="$ICONV_LIBS -liconv"
+ if test $os_win32 = yes; then
+ # Don't pointlessly auto-export the global symbols
+ # from a potentially static libiconv.a
+ ICONV_LIBS="$ICONV_LIBS -Wl,--exclude-libs=libiconv.a"
+ fi
have_iconv=yes
else
CFLAGS="$save_CFLAGS"