aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorMatthew Barnes <mbarnes@redhat.com>2009-09-24 04:41:27 +0800
committerMatthew Barnes <mbarnes@redhat.com>2009-09-24 04:41:27 +0800
commite48aee61c9646c7e4eaf2d5dc6f04fa5104c1e10 (patch)
tree185e239eb035cb3c6ecfbb1557c5c936e9834e1b /configure.ac
parent60f483c4edfc89025e8319fad839a21d024b0083 (diff)
downloadgsoc2013-evolution-e48aee61c9646c7e4eaf2d5dc6f04fa5104c1e10.tar
gsoc2013-evolution-e48aee61c9646c7e4eaf2d5dc6f04fa5104c1e10.tar.gz
gsoc2013-evolution-e48aee61c9646c7e4eaf2d5dc6f04fa5104c1e10.tar.bz2
gsoc2013-evolution-e48aee61c9646c7e4eaf2d5dc6f04fa5104c1e10.tar.lz
gsoc2013-evolution-e48aee61c9646c7e4eaf2d5dc6f04fa5104c1e10.tar.xz
gsoc2013-evolution-e48aee61c9646c7e4eaf2d5dc6f04fa5104c1e10.tar.zst
gsoc2013-evolution-e48aee61c9646c7e4eaf2d5dc6f04fa5104c1e10.zip
Rework optional plugin detection to fix distcheck.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac97
1 files changed, 47 insertions, 50 deletions
diff --git a/configure.ac b/configure.ac
index 253164d251..1edf01eadc 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1727,50 +1727,17 @@ AC_ARG_ENABLE([plugins],
dnl Add any new plugins here
plugins_base_always="calendar-file calendar-http $CALENDAR_WEATHER itip-formatter plugin-manager default-source addressbook-file startup-wizard mark-all-read groupwise-features publish-calendar caldav imap-features google-account-setup webdav-account-setup"
-plugins_base="$plugins_base_always $SA_JUNK_PLUGIN $BF_JUNK_PLUGIN $EXCHANGE_PLUGIN"
-all_plugins_base="$plugins_base_always sa-junk-plugin bogo-junk-plugin"
+plugins_base="$plugins_base_always $SA_JUNK_PLUGIN $BF_JUNK_PLUGIN"
+dist_plugins_base="$plugins_base_always exchange-operations sa-junk-plugin bogo-junk-plugin"
-plugins_standard_always="bbdb subject-thread save-calendar mail-to-task mailing-list-actions default-mailer prefer-plain mail-notification attachment-reminder backup-restore email-custom-header templates pst-import vcard-inline"
+plugins_standard_always="bbdb subject-thread save-calendar mail-to-task mailing-list-actions default-mailer prefer-plain mail-notification attachment-reminder backup-restore email-custom-header templates vcard-inline"
plugins_standard="$plugins_standard_always"
-all_plugins_standard="$plugins_standard"
+dist_plugins_standard="$plugins_standard audio-inline pst-import"
plugins_experimental_always="face external-editor hula-account-setup"
plugins_experimental="$plugins_experimental_always $TNEF_ATTACHMENTS"
-all_plugins_experimental="$plugins_experimental_always tnef-attachments"
-
-case x"$enable_plugins" in
-xno)
- plugins_enabled=""
- msg_plugins="no (some core functionality will not be available)"
- ;;
-xall | x | xyes)
- plugins_enabled="$plugins_base $plugins_standard"
- msg_plugins="yes (all)"
- ;;
-xbase)
- plugins_enabled="$plugins_base"
- msg_plugins="yes ($plugins_base)"
- ;;
-xexperimental)
- plugins_enabled="$plugins_base $plugins_standard $plugins_experimental"
- msg_plugins="yes ($plugins_base $plugins_standard $plugins_experimental)"
- ;;
-*)
- plugins_enabled="$enable_plugins"
- msg_plugins="yes ($enable_plugins)"
- ;;
-esac
-
-dnl Temporary KILL-BONOBO hack
-for broken_plugin in exchange-operations
-do
- if echo ${plugins_enabled} | grep "$broken_plugin" > /dev/null
- then
- plugins_enabled=`echo $plugins_enabled | sed -e "s/$broken_plugin//g"`
- echo "warning: plugin $broken_plugin is broken with kill-bonobo changes, disabling it."
- fi
-done
+dist_plugins_experimental="$plugins_experimental_always profiler tnef-attachments"
dnl ******************************
dnl Profiling support
@@ -1782,17 +1749,11 @@ AC_ARG_ENABLE([profiling],
case x"$enable_profiling" in
x | xyes)
- plugins_enabled="$plugins_enabled profiler"
- msg_plugins="$msg_plugins (and profiling)"
+ plugins_experimental="$plugins_experimental profiler"
AC_DEFINE(ENABLE_PROFILING,1,[Profiling Hooks Enabled])
;;
esac
-AC_SUBST(plugins_enabled)
-AC_SUBST(all_plugins_base)
-AC_SUBST(all_plugins_standard)
-AC_SUBST(all_plugins_experimental)
-
dnl ******************************************************************
dnl The following plugins have additional library dependencies.
dnl They must be explicitly disabled if the libraries are not present.
@@ -1812,8 +1773,7 @@ if test "x$enable_audio_inline" = "xyes"; then
AC_SUBST(GSTREAMER_LIBS)
if test "$have_gst" = "yes"; then
- plugins_enabled="$plugins_enabled audio-inline"
- msg_plugins="$msg_plugins (audio-inline)"
+ plugins_standard="$plugins_standard audio-inline"
else
AC_MSG_ERROR([gstreamer-0.10 is required for the audio-inline plugin. Use --disable-audio-inline to exclude the plugin.])
fi
@@ -1834,8 +1794,8 @@ if test "x$enable_exchange" = "xyes"; then
if test "x$have_libexchange" = "xyes"; then
AC_SUBST(CAMEL_EXCHANGE_CFLAGS)
AC_SUBST(CAMEL_EXCHANGE_LIBS)
- EXCHANGE_PLUGIN="exchange-operations"
msg_exchange="yes"
+ plugins_base="$plugins_base exchange-operations"
EVO_SET_COMPILE_FLAGS(CAMEL_EXCHANGE, libbonoboui-2.0 libglade-2.0 gconf-2.0 camel-provider-$EDS_PACKAGE
libebook-$EDS_PACKAGE libedataserverui-$EDS_PACKAGE libexchange-storage-$EDS_PACKAGE libecal-$EDS_PACKAGE)
else
@@ -1858,13 +1818,50 @@ if test "x$enable_pst" = "xyes"; then
AC_SUBST(LIBPST_LIBS)
if test "x$have_pst" = "xyes"; then
- plugins_enabled="$plugins_enabled pst-import"
- msg_plugins="$msg_plugins (pst-import)"
+ plugins_standard="$plugins_standard pst-import"
else
AC_MSG_ERROR([libpst is required for the pst-import plugin. Use --disable-pst-import to exclude the plugin.])
fi
fi
+case x"$enable_plugins" in
+xno)
+ plugins_enabled=""
+ msg_plugins="no (some core functionality will not be available)"
+ ;;
+xall | x | xyes)
+ plugins_enabled="$plugins_base $plugins_standard"
+ msg_plugins="yes (all)"
+ ;;
+xbase)
+ plugins_enabled="$plugins_base"
+ msg_plugins="yes ($plugins_base)"
+ ;;
+xexperimental)
+ plugins_enabled="$plugins_base $plugins_standard $plugins_experimental"
+ msg_plugins="yes ($plugins_base $plugins_standard $plugins_experimental)"
+ ;;
+*)
+ plugins_enabled="$enable_plugins"
+ msg_plugins="yes ($enable_plugins)"
+ ;;
+esac
+
+dnl Temporary KILL-BONOBO hack
+for broken_plugin in exchange-operations
+do
+ if echo ${plugins_enabled} | grep "$broken_plugin" > /dev/null
+ then
+ plugins_enabled=`echo $plugins_enabled | sed -e "s/$broken_plugin//g"`
+ echo "warning: plugin $broken_plugin is broken with kill-bonobo changes, disabling it."
+ fi
+done
+
+AC_SUBST(plugins_enabled)
+AC_SUBST(dist_plugins_base)
+AC_SUBST(dist_plugins_standard)
+AC_SUBST(dist_plugins_experimental)
+
dnl ***********
dnl GConf stuff
dnl ***********