aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorJeff Cai <jeff.cai@sun.com>2009-06-15 06:11:34 +0800
committerTobias Mueller <tobiasmue@gnome.org>2009-06-15 06:11:34 +0800
commitde854d79ce787888e84ca570c01ecaec97a11324 (patch)
treeac7a07843d0ea3d235b5d8ade0865ad6c850b2c3 /configure.ac
parent1276d2a9b42398e7ec978efc24e99aa6cd31e631 (diff)
downloadgsoc2013-evolution-de854d79ce787888e84ca570c01ecaec97a11324.tar
gsoc2013-evolution-de854d79ce787888e84ca570c01ecaec97a11324.tar.gz
gsoc2013-evolution-de854d79ce787888e84ca570c01ecaec97a11324.tar.bz2
gsoc2013-evolution-de854d79ce787888e84ca570c01ecaec97a11324.tar.lz
gsoc2013-evolution-de854d79ce787888e84ca570c01ecaec97a11324.tar.xz
gsoc2013-evolution-de854d79ce787888e84ca570c01ecaec97a11324.tar.zst
gsoc2013-evolution-de854d79ce787888e84ca570c01ecaec97a11324.zip
Don't link against libsoftoken3 explicitly
Fixes bug 585523.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 2fa56eacda..035f38d09e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1207,7 +1207,7 @@ if test "x${enable_nss}" = "xyes" || test "x${enable_nss}" = "xstatic"; then
esac
fi
else
- nsslibs="-lssl3 -lsmime3 -lnss3 $SOFTOKN3_LIB"
+ nsslibs="-lssl3 -lsmime3 -lnss3"
fi
AC_CACHE_CHECK([for Mozilla nss libraries], moz_nss_libs,
@@ -1217,7 +1217,7 @@ if test "x${enable_nss}" = "xyes" || test "x${enable_nss}" = "xstatic"; then
LIBS="$nsslibs $nsprlibs"
AC_TRY_LINK_FUNC(NSS_Init, moz_nss_libs="yes", moz_nss_libs="no")
if test "$moz_nss_libs" = no; then
- nsslibs="-lssl3 -lsmime3 -lnss3 $SOFTOKN3_LIB"
+ nsslibs="-lssl3 -lsmime3 -lnss3"
LDFLAGS="$LDFLAGS -L$with_nspr_libs $nsprlibs -L$with_nss_libs $nsslibs"
AC_TRY_LINK_FUNC(NSS_Init, moz_nss_libs="yes", moz_nss_libs="no")
fi