aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorMilan Crha <mcrha@redhat.com>2010-12-13 20:07:12 +0800
committerMilan Crha <mcrha@redhat.com>2010-12-13 20:07:12 +0800
commitda223fce69fe73305c0ab03abd4f092a72686556 (patch)
treea98a1afa1a52e40bf7d0e204d889a6e8ba12f5c9 /configure.ac
parent61b52bb8727bb6a047f98048c4c3a9c8fd375be1 (diff)
downloadgsoc2013-evolution-da223fce69fe73305c0ab03abd4f092a72686556.tar
gsoc2013-evolution-da223fce69fe73305c0ab03abd4f092a72686556.tar.gz
gsoc2013-evolution-da223fce69fe73305c0ab03abd4f092a72686556.tar.bz2
gsoc2013-evolution-da223fce69fe73305c0ab03abd4f092a72686556.tar.lz
gsoc2013-evolution-da223fce69fe73305c0ab03abd4f092a72686556.tar.xz
gsoc2013-evolution-da223fce69fe73305c0ab03abd4f092a72686556.tar.zst
gsoc2013-evolution-da223fce69fe73305c0ab03abd4f092a72686556.zip
Bug #616452 - Do not set '-Wl,--no-undefined' on freebsd/openbsd
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 8 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 53be44215c..ea2e5ed5e4 100644
--- a/configure.ac
+++ b/configure.ac
@@ -175,7 +175,14 @@ dnl -DE_CAL_DISABLE_DEPRECATED
AM_CPPFLAGS="$WARNING_FLAGS -fno-strict-aliasing"
AC_SUBST(AM_CPPFLAGS)
-LDFLAGS="$LDFLAGS -Wl,--no-undefined"
+case "$host" in
+*openbsd*|*freebsd*)
+ dnl Do not set '-Wl,--no-undefined' on freebsd/openbsd
+ ;;
+*)
+ LDFLAGS="$LDFLAGS -Wl,--no-undefined"
+ ;;
+esac
AC_CANONICAL_HOST
AC_DEFINE_UNQUOTED(VERSION_COMMENT, "", [Define if you want a comment appended to the version number])