aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorMatthew Barnes <mbarnes@redhat.com>2011-02-04 21:49:12 +0800
committerMatthew Barnes <mbarnes@redhat.com>2012-06-03 11:00:42 +0800
commitd21230f743de72ff73ed4aa22149175346d4d6ce (patch)
tree4ee17bbfe83bcafce7f229362e2535201c44abf9 /configure.ac
parentc030e2f0a57ee68c5a512df0cd0cea06346a50bc (diff)
downloadgsoc2013-evolution-d21230f743de72ff73ed4aa22149175346d4d6ce.tar
gsoc2013-evolution-d21230f743de72ff73ed4aa22149175346d4d6ce.tar.gz
gsoc2013-evolution-d21230f743de72ff73ed4aa22149175346d4d6ce.tar.bz2
gsoc2013-evolution-d21230f743de72ff73ed4aa22149175346d4d6ce.tar.lz
gsoc2013-evolution-d21230f743de72ff73ed4aa22149175346d4d6ce.tar.xz
gsoc2013-evolution-d21230f743de72ff73ed4aa22149175346d4d6ce.tar.zst
gsoc2013-evolution-d21230f743de72ff73ed4aa22149175346d4d6ce.zip
Add 'cal-config-weather' module.
Registers the "Weather" backend in ECalSourceConfig widgets. Replaces the 'calendar-weather' plugin.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 5 insertions, 6 deletions
diff --git a/configure.ac b/configure.ac
index 6424e769f9..148b6895dd 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1301,7 +1301,7 @@ dnl Add any new plugins here
plugins_base_always="calendar-http itip-formatter default-source mark-all-read publish-calendar imap-features"
plugins_base="$plugins_base_always"
-dist_plugins_base="$plugins_base_always calendar-weather"
+dist_plugins_base="$plugins_base_always"
plugins_standard_always="bbdb save-calendar mail-to-task mailing-list-actions prefer-plain mail-notification attachment-reminder email-custom-header face templates vcard-inline dbx-import external-editor"
@@ -1352,10 +1352,8 @@ if test "x$enable_weather" != "xno"; then
AC_SUBST(GWEATHER_CFLAGS)
AC_SUBST(GWEATHER_LIBS)
- if test "x$have_weather" = "xyes"; then
- plugins_base="$plugins_base calendar-weather"
- else
- AC_MSG_ERROR([gweather-3.0 >= gweather_minimum_version is required for configuring weather calendars. Use --disable-weather to disable this features.])
+ if test "x$have_weather" = "xno"; then
+ AC_MSG_ERROR([gweather-3.0 >= gweather_minimum_version is required for configuring weather calendars. Use --disable-weather to disable this feature.])
fi
dnl gweather-3.5 introduces API changes we do not yet support.
@@ -1363,6 +1361,7 @@ if test "x$enable_weather" != "xno"; then
AC_MSG_ERROR([gweather-3.5 is not yet supported. Install gweather-3.4 or specify --disable-weather as a configure option to exclude the calendar-weather plugin.])
fi
fi
+AM_CONDITIONAL(ENABLE_WEATHER, [test "x$enable_weather" != "xno"])
dnl ********************************************************************
dnl maps in contacts preview requires champlain-gtk, geoclue and clutter
@@ -1641,6 +1640,7 @@ modules/cal-config-caldav/Makefile
modules/cal-config-contacts/Makefile
modules/cal-config-google/Makefile
modules/cal-config-local/Makefile
+modules/cal-config-weather/Makefile
modules/composer-autosave/Makefile
modules/mailto-handler/Makefile
modules/mdn/Makefile
@@ -1658,7 +1658,6 @@ plugins/attachment-reminder/Makefile
plugins/audio-inline/Makefile
plugins/bbdb/Makefile
plugins/calendar-http/Makefile
-plugins/calendar-weather/Makefile
plugins/dbx-import/Makefile
plugins/default-source/Makefile
plugins/email-custom-header/Makefile