aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorMatthew Barnes <mbarnes@redhat.com>2012-06-03 04:52:01 +0800
committerMatthew Barnes <mbarnes@redhat.com>2012-06-03 04:52:01 +0800
commitceea3a0a1feaa25b8022852b52b7dab1bdf5eb5d (patch)
tree55a3020880ccdde5a4a53bb7649d4f3efc5e2de2 /configure.ac
parent184ec36d35db3c2e0377a1845390070a23a7cf64 (diff)
downloadgsoc2013-evolution-ceea3a0a1feaa25b8022852b52b7dab1bdf5eb5d.tar
gsoc2013-evolution-ceea3a0a1feaa25b8022852b52b7dab1bdf5eb5d.tar.gz
gsoc2013-evolution-ceea3a0a1feaa25b8022852b52b7dab1bdf5eb5d.tar.bz2
gsoc2013-evolution-ceea3a0a1feaa25b8022852b52b7dab1bdf5eb5d.tar.lz
gsoc2013-evolution-ceea3a0a1feaa25b8022852b52b7dab1bdf5eb5d.tar.xz
gsoc2013-evolution-ceea3a0a1feaa25b8022852b52b7dab1bdf5eb5d.tar.zst
gsoc2013-evolution-ceea3a0a1feaa25b8022852b52b7dab1bdf5eb5d.zip
Reduce diff noise with 'account-mgmt' branch.
One last time.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 6 insertions, 6 deletions
diff --git a/configure.ac b/configure.ac
index 4f906ce06d..3c97767a19 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1336,15 +1336,15 @@ if test "x$enable_audio_inline" = "xyes"; then
fi
fi
-dnl *****************************************
-dnl calendar-weather plugin requires gweather
-dnl *****************************************
+dnl **************************************
+dnl Weather calendars require gweather-3.0
+dnl **************************************
AC_ARG_ENABLE([weather],
[AS_HELP_STRING([--enable-weather],
- [Enable calendar-weather plugin @<:@default=yes@:>@])],
+ [Enable weather calendars @<:@default=yes@:>@])],
[enable_weather="$enableval"],[enable_weather=yes])
-if test "x$enable_weather" = "xyes"; then
+if test "x$enable_weather" != "xno"; then
PKG_CHECK_MODULES([GWEATHER], gweather-3.0 >= gweather_minimum_version,
have_weather="yes", have_weather="no")
AC_SUBST(GWEATHER_CFLAGS)
@@ -1353,7 +1353,7 @@ if test "x$enable_weather" = "xyes"; then
if test "x$have_weather" = "xyes"; then
plugins_base="$plugins_base calendar-weather"
else
- AC_MSG_ERROR([gweather-3.0 >= gweather_minimum_version is required for the calendar-weather plugin. Use --disable-weather to exclude the plugin.])
+ AC_MSG_ERROR([gweather-3.0 >= gweather_minimum_version is required for configuring weather calendars. Use --disable-weather to disable this features.])
fi
dnl gweather-3.5 introduces API changes we do not yet support.