aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorMatthew Barnes <mbarnes@redhat.com>2011-02-02 22:34:50 +0800
committerRodrigo Moya <rodrigo@gnome-db.org>2011-06-30 00:41:30 +0800
commitca4b209ae64723c2a895f2d385ab9553c75fc2a3 (patch)
treea2398baba7a1ac17bc2f9d44c49a9a3ef9ea2f4a /configure.ac
parent768e57dfc5dad63a269a289a9847e468bf4bfa4d (diff)
downloadgsoc2013-evolution-ca4b209ae64723c2a895f2d385ab9553c75fc2a3.tar
gsoc2013-evolution-ca4b209ae64723c2a895f2d385ab9553c75fc2a3.tar.gz
gsoc2013-evolution-ca4b209ae64723c2a895f2d385ab9553c75fc2a3.tar.bz2
gsoc2013-evolution-ca4b209ae64723c2a895f2d385ab9553c75fc2a3.tar.lz
gsoc2013-evolution-ca4b209ae64723c2a895f2d385ab9553c75fc2a3.tar.xz
gsoc2013-evolution-ca4b209ae64723c2a895f2d385ab9553c75fc2a3.tar.zst
gsoc2013-evolution-ca4b209ae64723c2a895f2d385ab9553c75fc2a3.zip
Fix champlain-gtk checks in configure.ac.
Check for champlain-gtk-0.8 not 0.5, and drop the fallback to 0.4.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 2 insertions, 5 deletions
diff --git a/configure.ac b/configure.ac
index 787f197e72..f083996c5e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1493,15 +1493,12 @@ if test "x$enable_plugins" = "xexperimental"; then
[enable_contacts_map="$enableval"], [enable_contacts_map=yes])
if test "x$enable_contacts_map" = "xyes"; then
- PKG_CHECK_MODULES([CHAMPLAIN], [champlain-gtk-0.5 >= champlain_minimum_version], [have_champlain=yes], [have_champlain=no])
- if test "x$have_champlain" = "xno"; then
- PKG_CHECK_MODULES([CHAMPLAIN], [champlain-gtk-0.4 >= champlain_minimum_version], [have_champlain=yes], [have_champlain=no])
- fi
+ PKG_CHECK_MODULES([CHAMPLAIN], [champlain-gtk-0.8 >= champlain_minimum_version], [have_champlain=yes], [have_champlain=no])
AC_SUBST(CHAMPLAIN_CFLAGS)
AC_SUBST(CHAMPLAIN_LIBS)
if test "x$have_champlain" = "xno"; then
- AC_MSG_ERROR([champlain-gtk >= champlain_minimum_version is required for the contacts-map plugin. Use --disable-contacts-map to exclude the plugin.])
+ AC_MSG_ERROR([champlain-gtk-0.8 >= champlain_minimum_version is required for the contacts-map plugin. Use --disable-contacts-map to exclude the plugin.])
fi
PKG_CHECK_MODULES([GEOCLUE], [geoclue >= geoclue_minimum_version], [have_geoclue=yes], [have_geoclue=no])