aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorTor Lillqvist <tml@iki.fi>2009-11-11 21:34:28 +0800
committerTor Lillqvist <tml@iki.fi>2009-11-11 21:34:28 +0800
commitc8b9dd726262a5fcaff7085fc642298c03fa4782 (patch)
tree6ab9283061970162c4862d526d1186a99bcd322d /configure.ac
parent43a98ec41e2bd0d437eaea8db3021ad181455f8c (diff)
downloadgsoc2013-evolution-c8b9dd726262a5fcaff7085fc642298c03fa4782.tar
gsoc2013-evolution-c8b9dd726262a5fcaff7085fc642298c03fa4782.tar.gz
gsoc2013-evolution-c8b9dd726262a5fcaff7085fc642298c03fa4782.tar.bz2
gsoc2013-evolution-c8b9dd726262a5fcaff7085fc642298c03fa4782.tar.lz
gsoc2013-evolution-c8b9dd726262a5fcaff7085fc642298c03fa4782.tar.xz
gsoc2013-evolution-c8b9dd726262a5fcaff7085fc642298c03fa4782.tar.zst
gsoc2013-evolution-c8b9dd726262a5fcaff7085fc642298c03fa4782.zip
Ensure "pkcs12.h" is the mozilla-nss one and not the gnutls one
Put the Mozilla NSS CFLAGS before the GnuTLS ones in CERT_UI_CFLAGS. Also, drop unnecessary EVOLUTION_ADDRESSBOOK_CFLAGS in smime/lib/Makefile.am.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 10 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index a9a91f7b5d..f545ee3dec 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1243,7 +1243,16 @@ fi
dnl ******************************
dnl CERT_UI Flags
dnl ******************************
-EVO_SET_COMPILE_FLAGS(CERT_UI, libedataserverui-$EDS_PACKAGE libglade-2.0 gthread-2.0, $MANUAL_NSS_CFLAGS $MOZILLA_NSS_CFLAGS, $MOZILLA_L_DIR $MANUAL_NSS_LIBS $MOZILLA_NSS_LIBS)
+dnl
+dnl Here we want the Mozilla flags to go *before* the other ones,
+dnl especially the mozilla-nss -I flags to go before the gnutls ones
+dnl (which are dragged in through libedataserverui), as both
+dnl gnutls and mozilla-nss have a header called "pkcs12.h" which is
+dnl included in smime/lib/e-pkcs12.c. It wants the Mozilla NSS one.
+dnl
+EVO_SET_COMPILE_FLAGS(CERT_UI, libedataserverui-$EDS_PACKAGE libglade-2.0 gthread-2.0)
+CERT_UI_CFLAGS="$MANUAL_NSS_CFLAGS $MOZILLA_NSS_CFLAGS $CERT_UI_CFLAGS"
+CERT_UI_LIBS="$MOZILLA_L_DIR $MANUAL_NSS_LIBS $MOZILLA_NSS_LIBS $CERT_UI_LIBS"
AC_SUBST(CERT_UI_CFLAGS)
AC_SUBST(CERT_UI_LIBS)