aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorMatthew Barnes <mbarnes@redhat.com>2011-07-12 19:06:12 +0800
committerRodrigo Moya <rodrigo@gnome-db.org>2011-09-14 20:08:36 +0800
commitc238fbfd1525aa282673abdc435a7f9e4a7f7f3e (patch)
tree4032b73901eebd34a00100cd458cfa13cd472c7b /configure.ac
parentcabf0e563627d5765a459da23b79bdb09b2c1284 (diff)
downloadgsoc2013-evolution-c238fbfd1525aa282673abdc435a7f9e4a7f7f3e.tar
gsoc2013-evolution-c238fbfd1525aa282673abdc435a7f9e4a7f7f3e.tar.gz
gsoc2013-evolution-c238fbfd1525aa282673abdc435a7f9e4a7f7f3e.tar.bz2
gsoc2013-evolution-c238fbfd1525aa282673abdc435a7f9e4a7f7f3e.tar.lz
gsoc2013-evolution-c238fbfd1525aa282673abdc435a7f9e4a7f7f3e.tar.xz
gsoc2013-evolution-c238fbfd1525aa282673abdc435a7f9e4a7f7f3e.tar.zst
gsoc2013-evolution-c238fbfd1525aa282673abdc435a7f9e4a7f7f3e.zip
Convert junk filtering EPlugins to EExtensions.
We now have a proper junk mail filtering API. All junk filtering extensions must subclass EMailJunkFilter for user preferences and availability testing, and implement the CamelJunkFilter interface for the actual junk filtering and learning operations. The bogofilter module should be feature-equivalent to its former EPlugin. The spamassassin module is far more complex. It's nearly feature-equivalent to its former EPlugin, but I ditched the spamd respawning code since it seemed unnecessary for a mail client to have to deal with. If there's a huge outcry from users about it I'll reluctantly put it back, but I don't expect one. This gets us a step closer to killing off EConfig, and eventually the EPlugin framework itself.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 4 insertions, 8 deletions
diff --git a/configure.ac b/configure.ac
index 474d20b449..8ba00a265e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -198,8 +198,6 @@ case "$host" in
os_win32=yes
NO_UNDEFINED='-no-undefined'
SOEXT='.dll'
- SA_JUNK_PLUGIN=''
- BF_JUNK_PLUGIN=''
DL_LIB=''
SOFTOKN3_LIB=''
CHAMPLAIN_REQUIREMENT=''
@@ -218,8 +216,6 @@ case "$host" in
os_win32=no
NO_UNDEFINED='-no-undefined'
SOEXT='.so'
- SA_JUNK_PLUGIN=sa-junk-plugin
- BF_JUNK_PLUGIN=bogo-junk-plugin
DL_LIB='-ldl'
SOFTOKN3_LIB='-lsoftokn3'
;;
@@ -1437,8 +1433,8 @@ AC_ARG_ENABLE([plugins],
dnl Add any new plugins here
plugins_base_always="calendar-file calendar-http itip-formatter default-source addressbook-file mark-all-read publish-calendar caldav imap-features google-account-setup webdav-account-setup"
-plugins_base="$plugins_base_always $SA_JUNK_PLUGIN $BF_JUNK_PLUGIN"
-dist_plugins_base="$plugins_base_always calendar-weather sa-junk-plugin bogo-junk-plugin"
+plugins_base="$plugins_base_always"
+dist_plugins_base="$plugins_base_always calendar-weather"
plugins_standard_always="bbdb save-calendar mail-to-task mailing-list-actions prefer-plain mail-notification attachment-reminder backup-restore email-custom-header face templates vcard-inline dbx-import"
@@ -1754,6 +1750,7 @@ mail/importers/Makefile
maint/Makefile
modules/Makefile
modules/addressbook/Makefile
+modules/bogofilter/Makefile
modules/calendar/Makefile
modules/mail/Makefile
modules/composer-autosave/Makefile
@@ -1766,6 +1763,7 @@ modules/plugin-lib/Makefile
modules/plugin-manager/Makefile
modules/plugin-mono/Makefile
modules/plugin-python/Makefile
+modules/spamassassin/Makefile
modules/startup-wizard/Makefile
modules/windows-sens/Makefile
plugins/Makefile
@@ -1774,7 +1772,6 @@ plugins/attachment-reminder/Makefile
plugins/audio-inline/Makefile
plugins/backup-restore/Makefile
plugins/bbdb/Makefile
-plugins/bogo-junk-plugin/Makefile
plugins/caldav/Makefile
plugins/calendar-file/Makefile
plugins/calendar-http/Makefile
@@ -1795,7 +1792,6 @@ plugins/mark-all-read/Makefile
plugins/prefer-plain/Makefile
plugins/pst-import/Makefile
plugins/publish-calendar/Makefile
-plugins/sa-junk-plugin/Makefile
plugins/save-calendar/Makefile
plugins/templates/Makefile
plugins/tnef-attachments/Makefile