aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorMatthew Barnes <mbarnes@redhat.com>2010-03-20 23:38:33 +0800
committerMichael Meeks <michael.meeks@novell.com>2010-04-07 19:13:02 +0800
commitb674497bccae2ec2ac914714d34961a9517a8aa7 (patch)
tree599aee6c071255d3944a102fbd448a17ecaa322c /configure.ac
parenta718e57b258d993e8427bff2ee8a4eccf89a582f (diff)
downloadgsoc2013-evolution-b674497bccae2ec2ac914714d34961a9517a8aa7.tar
gsoc2013-evolution-b674497bccae2ec2ac914714d34961a9517a8aa7.tar.gz
gsoc2013-evolution-b674497bccae2ec2ac914714d34961a9517a8aa7.tar.bz2
gsoc2013-evolution-b674497bccae2ec2ac914714d34961a9517a8aa7.tar.lz
gsoc2013-evolution-b674497bccae2ec2ac914714d34961a9517a8aa7.tar.xz
gsoc2013-evolution-b674497bccae2ec2ac914714d34961a9517a8aa7.tar.zst
gsoc2013-evolution-b674497bccae2ec2ac914714d34961a9517a8aa7.zip
Convert NetworkManager integration to an EShell extension.
This demonstrates how to extend EShell without having to modify and recompile e-shell.c. If NetworkManager integration is enabled, the extension is loaded automatically when the EShell is created. The same pattern can be applied to integrate other network monitoring software like ConnMan or Microsoft's Wireless Zero Configuration.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac15
1 files changed, 6 insertions, 9 deletions
diff --git a/configure.ac b/configure.ac
index c5f630725b..7e88758f1e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1133,18 +1133,14 @@ AC_ARG_ENABLE([nm],
AC_MSG_CHECKING([if NetworkManager support is enabled])
AC_MSG_RESULT([$enable_nm])
if test "$enable_nm" = yes; then
- PKG_CHECK_MODULES([NM], [NetworkManager >= nm_minimum_version],
- [NM_SUPPORT="yes"],
- [AC_MSG_ERROR([NetworkManager not found (or version < nm_minimum_version)!
- If you want to disable NetworkManager, please append --disable-nm to configure!])])
- AC_DEFINE(NM_SUPPORT, 1, [network manager available])
+ PKG_CHECK_MODULES([NM], [NetworkManager >= nm_minimum_version],,
+ [AC_MSG_ERROR([NetworkManager not found (or version < nm_minimum_version).
+ If you want to disable NetworkManager, please append --disable-nm to configure.])])
AC_SUBST(HAVE_NM)
AC_SUBST(NM_CFLAGS)
-else
- NM_SUPPORT="no"
fi
-AM_CONDITIONAL([NM_SUPPORT], [test "$NM_SUPPORT" = yes])
+AM_CONDITIONAL([ENABLE_NETWORK_MANAGER], [test "$enable_nm" = yes])
dnl ******************************
dnl Camel Flags
@@ -1693,6 +1689,7 @@ modules/Makefile
modules/addressbook/Makefile
modules/calendar/Makefile
modules/mail/Makefile
+modules/network-manager/Makefile
modules/plugin-lib/Makefile
modules/plugin-mono/Makefile
modules/plugin-python/Makefile
@@ -1763,7 +1760,7 @@ fi
echo "
LDAP support: $msg_ldap
- NetworkManager: $NM_SUPPORT
+ NetworkManager: $enable_nm
Pilot conduits: $msg_pilot
Libnotify: $HAVE_LIBNOTIFY
Kerberos 5: $msg_krb5