aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorMilan Crha <mcrha@redhat.com>2009-06-05 20:48:29 +0800
committerMatthew Barnes <mbarnes@redhat.com>2009-06-09 19:18:28 +0800
commitb0e26e9c5f13c710c7677959cc457158206befe1 (patch)
treeb4a7791f26ff0928e862d9d44b3b81e52cd986e0 /configure.ac
parentf9f7c3efa62b85e8f54e59382fef9ef8c80df6e6 (diff)
downloadgsoc2013-evolution-b0e26e9c5f13c710c7677959cc457158206befe1.tar
gsoc2013-evolution-b0e26e9c5f13c710c7677959cc457158206befe1.tar.gz
gsoc2013-evolution-b0e26e9c5f13c710c7677959cc457158206befe1.tar.bz2
gsoc2013-evolution-b0e26e9c5f13c710c7677959cc457158206befe1.tar.lz
gsoc2013-evolution-b0e26e9c5f13c710c7677959cc457158206befe1.tar.xz
gsoc2013-evolution-b0e26e9c5f13c710c7677959cc457158206befe1.tar.zst
gsoc2013-evolution-b0e26e9c5f13c710c7677959cc457158206befe1.zip
Fix even more compiler warnings and disable one for format strings
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 2 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index f272adf5ca..32c4e6c94b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -59,7 +59,7 @@ AS_COMPILER_FLAGS(WARNING_FLAGS,
-Wno-unused-parameter
-Wdeclaration-after-statement
-Werror-implicit-function-declaration
- -Wformat-nonliteral -Wformat-security -Winit-self
+ -Wformat-security -Winit-self
-Wmissing-declarations -Wmissing-include-dirs
-Wmissing-noreturn -Wnested-externs -Wpointer-arith
-Wredundant-decls -Wundef -Wwrite-strings")
@@ -70,6 +70,7 @@ AC_SUBST(WARNING_FLAGS)
#
# -Wmissing-format-attribute
# -Wshadow
+# -Wformat-nonliteral
CFLAGS="$CFLAGS $WARNING_FLAGS"