aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorMatthew Barnes <mbarnes@redhat.com>2012-09-30 22:52:52 +0800
committerMatthew Barnes <mbarnes@redhat.com>2012-10-04 10:07:28 +0800
commit79719fdd7cdb8642b61ce029044fcc9a3f86fccc (patch)
tree60c5a9d94216cfba7da7be4507287f308b55ac7c /configure.ac
parent2634f04217b160d671e11efc6adf64244b022750 (diff)
downloadgsoc2013-evolution-79719fdd7cdb8642b61ce029044fcc9a3f86fccc.tar
gsoc2013-evolution-79719fdd7cdb8642b61ce029044fcc9a3f86fccc.tar.gz
gsoc2013-evolution-79719fdd7cdb8642b61ce029044fcc9a3f86fccc.tar.bz2
gsoc2013-evolution-79719fdd7cdb8642b61ce029044fcc9a3f86fccc.tar.lz
gsoc2013-evolution-79719fdd7cdb8642b61ce029044fcc9a3f86fccc.tar.xz
gsoc2013-evolution-79719fdd7cdb8642b61ce029044fcc9a3f86fccc.tar.zst
gsoc2013-evolution-79719fdd7cdb8642b61ce029044fcc9a3f86fccc.zip
Bug 678750 - Use geocode-glib instead of geoclue
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac41
1 files changed, 32 insertions, 9 deletions
diff --git a/configure.ac b/configure.ac
index a6009dfd41..95f6ca979b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1341,26 +1341,49 @@ AC_ARG_ENABLE([contact-maps],
[enable_contact_maps="$enableval"], [enable_contact_maps="no"])
if test "x$enable_contact_maps" = "xyes"; then
- PKG_CHECK_MODULES([CHAMPLAIN], [champlain-gtk-0.12 >= champlain_minimum_version], [have_champlain=yes], [have_champlain=no])
+ PKG_CHECK_MODULES([CHAMPLAIN],
+ [champlain-gtk-0.12 >= champlain_minimum_version],
+ [have_champlain=yes], [have_champlain=no])
AC_SUBST(CHAMPLAIN_CFLAGS)
AC_SUBST(CHAMPLAIN_LIBS)
if test "x$have_champlain" = "xno"; then
- AC_MSG_ERROR([champlain-gtk-0.12 >= champlain_minimum_version is required for maps in contacts preview.])
+ AC_MSG_ERROR([
+
+ champlain-gtk-0.12 is required for contact maps.
+
+ If you want to disable the contact maps feature,
+ please append --disable-contact-maps to configure.
+ ])
fi
- PKG_CHECK_MODULES([GEOCLUE], [geoclue >= geoclue_minimum_version], [have_geoclue=yes], [have_geoclue=no])
- AC_SUBST(GEOCLUE_CFLAGS)
- AC_SUBST(GEOCLUE_LIBS)
+ PKG_CHECK_MODULES([GEO],
+ [geoclue >= geoclue_minimum_version
+ geocode-glib],
+ [have_geo=yes], [have_geo=no])
+
+ if test "x$have_geo" = "xno"; then
+ AC_MSG_ERROR([
- if test "x$have_geoclue" = "xno"; then
- AC_MSG_ERROR([geoclue is required for maps in contacts preview.])
+ geoclue and geocode-glib are required for contact maps.
+
+ If you want to disable the contact maps feature,
+ please append --disable-contact-maps to configure.
+ ])
fi
- PKG_CHECK_MODULES([CLUTTER_GTK], [clutter-gtk-1.0 >= clutter_gtk_minimum_version], [have_clutter_gtk="yes"], [have_clutter_gtk="no"] )
+ PKG_CHECK_MODULES([CLUTTER_GTK],
+ [clutter-gtk-1.0 >= clutter_gtk_minimum_version],
+ [have_clutter_gtk="yes"], [have_clutter_gtk="no"])
if test "x$have_clutter_gtk" = "xno"; then
- AC_MSG_ERROR([clutter-gtk-1.0 is required for maps in contacts preview.])
+ AC_MSG_ERROR([
+
+ clutter-gtk-1.0 is required for contact maps.
+
+ If you want to disable the contact maps feature,
+ please append --disable-contact-maps to configure.
+ ])
fi
AC_DEFINE(WITH_CONTACT_MAPS, 1, [When defined contacts preview will contain maps])