aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorAntoine Jacoutot <ajacoutot@openbsd.org>2011-07-13 05:28:14 +0800
committerRodrigo Moya <rodrigo@gnome-db.org>2011-09-14 20:08:36 +0800
commit6f16d81fbc965d77e25da8cc557b335985689c67 (patch)
tree8c7f23c436f99aac7f01a6159f9a23e3476b8c8a /configure.ac
parent0c449e92e69861657c34e279af285265792cc656 (diff)
downloadgsoc2013-evolution-6f16d81fbc965d77e25da8cc557b335985689c67.tar
gsoc2013-evolution-6f16d81fbc965d77e25da8cc557b335985689c67.tar.gz
gsoc2013-evolution-6f16d81fbc965d77e25da8cc557b335985689c67.tar.bz2
gsoc2013-evolution-6f16d81fbc965d77e25da8cc557b335985689c67.tar.lz
gsoc2013-evolution-6f16d81fbc965d77e25da8cc557b335985689c67.tar.xz
gsoc2013-evolution-6f16d81fbc965d77e25da8cc557b335985689c67.tar.zst
gsoc2013-evolution-6f16d81fbc965d77e25da8cc557b335985689c67.zip
Fix OpenBSD/FreeBSD support
Move the "$host" down when $host is actually set (that is after AC_CANONICAL_HOST). Don't set DL_LIB to libdl which is not available on OpenBSD/FreeBSD and set NO_UNDEFINED to null. https://bugzilla.gnome.org/show_bug.cgi?id=654478
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac15
1 files changed, 13 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 5d380f07e4..474d20b449 100644
--- a/configure.ac
+++ b/configure.ac
@@ -101,6 +101,10 @@ dnl -DE_CAL_DISABLE_DEPRECATED
AM_CPPFLAGS="$WARNING_FLAGS -fno-strict-aliasing"
AC_SUBST(AM_CPPFLAGS)
+AC_CANONICAL_HOST
+AC_DEFINE_UNQUOTED(VERSION_COMMENT, "", [Define if you want a comment appended to the version number])
+
+dnl This must stay after AC_CANONICAL_HOST, which defines $host.
case "$host" in
*openbsd*|*freebsd*)
dnl Do not set '-Wl,--no-undefined' on freebsd/openbsd
@@ -110,8 +114,6 @@ case "$host" in
;;
esac
-AC_CANONICAL_HOST
-AC_DEFINE_UNQUOTED(VERSION_COMMENT, "", [Define if you want a comment appended to the version number])
dnl *************************************
dnl Put the ACLOCAL flags in the Makefile
@@ -203,6 +205,15 @@ case "$host" in
CHAMPLAIN_REQUIREMENT=''
GEOCLUE_REQUIREMENT=''
;;
+*openbsd*|*freebsd*)
+ os_win32=no
+ NO_UNDEFINED=''
+ SOEXT='.so'
+ SA_JUNK_PLUGIN=sa-junk-plugin
+ BF_JUNK_PLUGIN=bogo-junk-plugin
+ DL_LIB=''
+ SOFTOKN3_LIB='-lsoftokn3'
+ ;;
*)
os_win32=no
NO_UNDEFINED='-no-undefined'