aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorMatthew Barnes <mbarnes@redhat.com>2009-07-14 02:48:06 +0800
committerMatthew Barnes <mbarnes@redhat.com>2009-07-14 02:48:06 +0800
commit3bd46ea849351345825abbe6412f39e0e625c6c8 (patch)
tree5362bdf55f8d7aab4ce217ce35e5afa1c1773bfb /configure.ac
parent1e0b252fc78b0a96c621c5500a8140c9fcca6e9c (diff)
downloadgsoc2013-evolution-3bd46ea849351345825abbe6412f39e0e625c6c8.tar
gsoc2013-evolution-3bd46ea849351345825abbe6412f39e0e625c6c8.tar.gz
gsoc2013-evolution-3bd46ea849351345825abbe6412f39e0e625c6c8.tar.bz2
gsoc2013-evolution-3bd46ea849351345825abbe6412f39e0e625c6c8.tar.lz
gsoc2013-evolution-3bd46ea849351345825abbe6412f39e0e625c6c8.tar.xz
gsoc2013-evolution-3bd46ea849351345825abbe6412f39e0e625c6c8.tar.zst
gsoc2013-evolution-3bd46ea849351345825abbe6412f39e0e625c6c8.zip
Bug 588277 – Unnecessary special-purpose configure flag
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac16
1 files changed, 2 insertions, 14 deletions
diff --git a/configure.ac b/configure.ac
index 770bcfa37e..254ee9f01f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -242,18 +242,8 @@ dnl ******************************
dnl iconv checking
dnl ******************************
have_iconv=no
-AC_ARG_WITH([libiconv],
- AS_HELP_STRING([--with-libiconv=PATH],
- [Prefix where libiconv is installed]))
-if test -d "$withval"; then
- ICONV_CFLAGS="-I$withval/include"
- ICONV_LIBS="-L$withval/lib"
-fi
-
-save_CFLAGS="$CFLAGS"
save_LIBS="$LIBS"
-CFLAGS="$CFLAGS $ICONV_CFLAGS"
-LIBS="$LIBS $ICONV_LIBS -liconv"
+LIBS="$LIBS -liconv"
AC_CACHE_CHECK([for iconv in -liconv], [ac_cv_libiconv],
AC_LINK_IFELSE([AC_LANG_PROGRAM(
[[
@@ -267,7 +257,7 @@ AC_CACHE_CHECK([for iconv in -liconv], [ac_cv_libiconv],
)],[ac_cv_libiconv=yes],[ac_cv_libiconv=no]))
if test $ac_cv_libiconv = yes; then
- ICONV_LIBS="$ICONV_LIBS -liconv"
+ ICONV_LIBS="-liconv"
if test $os_win32 = yes; then
# Don't pointlessly auto-export the global symbols
# from a potentially static libiconv.a
@@ -275,7 +265,6 @@ if test $ac_cv_libiconv = yes; then
fi
have_iconv=yes
else
- CFLAGS="$save_CFLAGS"
LIBS="$save_LIBS"
AC_CHECK_FUNC(iconv, have_iconv=yes, have_iconv=no)
fi
@@ -321,7 +310,6 @@ fi
if test "$have_iconv" = no; then
AC_MSG_ERROR([You need to install a working iconv implementation, such as ftp://ftp.gnu.org/pub/gnu/libiconv])
fi
-AC_SUBST(ICONV_CFLAGS)
AC_SUBST(ICONV_LIBS)
CFLAGS="$CFLAGS -I$srcdir"