aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorMatthew Barnes <mbarnes@redhat.com>2013-05-28 21:36:33 +0800
committerMatthew Barnes <mbarnes@redhat.com>2013-05-28 21:42:12 +0800
commit3777e4887c286282b5e24b42328a6a660d7360c8 (patch)
tree9e07efc540129588c35f755cb03711dbedd76445 /configure.ac
parent13958f5ad55a53fada84d0b0679af9d38019c6aa (diff)
downloadgsoc2013-evolution-3777e4887c286282b5e24b42328a6a660d7360c8.tar
gsoc2013-evolution-3777e4887c286282b5e24b42328a6a660d7360c8.tar.gz
gsoc2013-evolution-3777e4887c286282b5e24b42328a6a660d7360c8.tar.bz2
gsoc2013-evolution-3777e4887c286282b5e24b42328a6a660d7360c8.tar.lz
gsoc2013-evolution-3777e4887c286282b5e24b42328a6a660d7360c8.tar.xz
gsoc2013-evolution-3777e4887c286282b5e24b42328a6a660d7360c8.tar.zst
gsoc2013-evolution-3777e4887c286282b5e24b42328a6a660d7360c8.zip
configure.ac: Remove unused function and header checks.
This removes the following definitions from config.h: CTIME_R_THREE_ARGS GETHOSTBYADDR_R_SEVEN_ARGS GETHOSTBYNAME_R_FIVE_ARGS HAVE_ISBLANK HAVE_MKSTEMP HAVE_STATFS HAVE_STATVFS HAVE_SYS_MOUNT_H HAVE_SYS_PARAM_H HAVE_SYS_STATVFS_H These were all either unused or unnecessarily used.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac106
1 files changed, 1 insertions, 105 deletions
diff --git a/configure.ac b/configure.ac
index 450f4f14e9..5f0418b555 100644
--- a/configure.ac
+++ b/configure.ac
@@ -486,111 +486,7 @@ else
fi
-AC_CHECK_FUNCS(mkstemp mkdtemp isblank)
-
-dnl **************************************************
-dnl ctime_r prototype
-dnl **************************************************
-
-AC_CACHE_CHECK([if ctime_r wants three arguments], [ac_cv_ctime_r_three_args],
-[
- AC_COMPILE_IFELSE([AC_LANG_PROGRAM(
- [[ #include <time.h> ]],
- [[ char *buf;
- time_t date;
- ctime_r (&date, buf, 100); ]]
- )],[ac_cv_ctime_r_three_args=yes],[ac_cv_ctime_r_three_args=no])
-])
-
-if test x"$ac_cv_ctime_r_three_args" = xyes ; then
- AC_DEFINE(CTIME_R_THREE_ARGS, 1, [Solaris-style ctime_r])
-fi
-
-dnl **************************************************
-dnl gethostbyname_r prototype
-dnl **************************************************
-
-AC_CHECK_FUNCS(gethostbyname_r,[
-AC_CACHE_CHECK([if gethostbyname_r wants five arguments], [ac_cv_gethostbyname_r_five_args],
-[
- AC_COMPILE_IFELSE([AC_LANG_PROGRAM(
- [[
- #include "confdefs.h"
- #include <sys/types.h>
- #include <sys/socket.h>
- #include <netinet/in.h>
- #include <netdb.h>
-
- #define BUFSIZE (sizeof(struct hostent)+10)
- ]],
- [[
- struct hostent hent;
- char buffer[BUFSIZE];
- int bufsize=BUFSIZE;
- int h_errno;
- (void)gethostbyname_r ("www.ximian.com", &hent, buffer, bufsize, &h_errno);
- ]]
- )],[ac_cv_gethostbyname_r_five_args=yes],[ac_cv_gethostbyname_r_five_args=no])
-])])
-
-if test "x$ac_cv_gethostbyname_r_five_args" = "xyes" ; then
- AC_DEFINE(GETHOSTBYNAME_R_FIVE_ARGS, 1, [Solaris-style gethostbyname_r])
-fi
-
-dnl **************************************************
-dnl gethostbyaddr_r prototype
-dnl **************************************************
-
-AC_CHECK_FUNCS(gethostbyaddr_r,[
-AC_CACHE_CHECK([if gethostbyaddr_r wants seven arguments], [ac_cv_gethostbyaddr_r_seven_args],
-[
- AC_COMPILE_IFELSE([AC_LANG_PROGRAM(
- [[
- #include "confdefs.h"
- #include <sys/types.h>
- #include <sys/socket.h>
- #include <netinet/in.h>
- #include <netdb.h>
- #define BUFSIZE (sizeof(struct hostent)+10)
- ]],
- [[
- struct hostent hent;
- char buffer[BUFSIZE];
- int bufsize=BUFSIZE;
- int h_errno;
- (void)gethostbyaddr_r ("www.ximian.com", 14, AF_INET, &hent, buffer, bufsize, &h_errno); ]]
- )],[ac_cv_gethostbyaddr_r_seven_args=yes],[ac_cv_gethostbyaddr_r_seven_args=no])
-])])
-
-if test "x$ac_cv_gethostbyaddr_r_seven_args" = "xyes" ; then
- AC_DEFINE(GETHOSTBYADDR_R_SEVEN_ARGS, 1, [Solaris-style gethostbyaddr_r])
-fi
-
-dnl **************************************************
-dnl stat(v)fs location/type
-dnl **************************************************
-
-AC_CHECK_HEADER([sys/statvfs.h],
- [AC_DEFINE([HAVE_SYS_STATVFS_H], 1, [Have <sys/statvfs.h>])],,
- [[ #if HAVE_SYS_STATVFS_H
- #include <sys/statvfs.h>
- #endif
- ]])
-AC_CHECK_FUNCS(statvfs)
-
-AC_CHECK_HEADER([sys/param.h],
- [AC_DEFINE([HAVE_SYS_PARAM_H], 1, [Have <sys/param.h>])],,
- [[ #if HAVE_SYS_PARAM_H
- #include <sys/param.h>
- #endif
- ]])
-AC_CHECK_HEADER([sys/mount.h],
- [AC_DEFINE([HAVE_SYS_MOUNT_H], 1, [Have <sys/mount.h>])],,
- [[ #if HAVE_SYS_MOUNT_H
- #include <sys/mount.h>
- #endif
- ]])
-AC_CHECK_FUNCS(statfs)
+AC_CHECK_FUNCS(mkdtemp)
dnl **************************************************
dnl Gnome Icon Theme