aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorCedric Bosdonnat <cedric.bosdonnat@free.fr>2009-11-30 18:46:13 +0800
committerMilan Crha <mcrha@redhat.com>2009-11-30 18:46:13 +0800
commit2ffe9818285d6bb5d0eb012da534a9dbc01355cc (patch)
tree54db8172cb9d2fb9abaf083b319f6d577a350836 /configure.ac
parent18eb9010af82404ced0981614fdf78edd2b60d27 (diff)
downloadgsoc2013-evolution-2ffe9818285d6bb5d0eb012da534a9dbc01355cc.tar
gsoc2013-evolution-2ffe9818285d6bb5d0eb012da534a9dbc01355cc.tar.gz
gsoc2013-evolution-2ffe9818285d6bb5d0eb012da534a9dbc01355cc.tar.bz2
gsoc2013-evolution-2ffe9818285d6bb5d0eb012da534a9dbc01355cc.tar.lz
gsoc2013-evolution-2ffe9818285d6bb5d0eb012da534a9dbc01355cc.tar.xz
gsoc2013-evolution-2ffe9818285d6bb5d0eb012da534a9dbc01355cc.tar.zst
gsoc2013-evolution-2ffe9818285d6bb5d0eb012da534a9dbc01355cc.zip
Bug #361156 - [contacts-map] Add check for clutter-gtk-0.10 too
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 7 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 65869fa9e2..35e111d3a2 100644
--- a/configure.ac
+++ b/configure.ac
@@ -60,6 +60,7 @@ m4_define([nm_minimum_version],[0.7])
m4_define([hal_minimum_version], [0.5.4])
m4_define([champlain_minimum_version], [0.4])
m4_define([geoclue_minimum_version], [0.11.1])
+m4_define([clutter_gtk_minimum_version], [0.10.0])
m4_define([libnotify_minimum_version], [0.3.0])
m4_define([gnome_pilot_minimum_version], [2.0.15])
m4_define([gweather_minimum_version], [2.25.3])
@@ -1560,6 +1561,12 @@ if test "x$enable_plugins" = "xexperimental"; then
AC_MSG_ERROR([geoclue is required for the contacts-map plugin. Use --disable-contacts-map to exclude the plugin.])
fi
+ PKG_CHECK_MODULES( [CLUTTER_GTK], [clutter-gtk-0.10 >= clutter_gtk_minimum_version], [have_clutter_gtk="yes"], [have_clutter_gtk="no"] )
+
+ if test "x$have_clutter_gtk" = "xno"; then
+ AC_MSG_ERROR([clutter_gtk is required for the contacts-map plugin. Use --disable-contacts-map to exclude the plugin.])
+ fi
+
plugins_standard="$plugins_standard contacts-map"
fi
fi