aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorMatthew Barnes <mbarnes@redhat.com>2011-02-02 22:34:50 +0800
committerMatthew Barnes <mbarnes@redhat.com>2011-02-02 22:38:36 +0800
commit1997f5cf6d478f2c7162b1b80699b165d0161ddc (patch)
treecacc8c478e1d41ca959b295949a4fc2c7a1385ff /configure.ac
parentcd437591d629ab74de140866b8a137067849b486 (diff)
downloadgsoc2013-evolution-1997f5cf6d478f2c7162b1b80699b165d0161ddc.tar
gsoc2013-evolution-1997f5cf6d478f2c7162b1b80699b165d0161ddc.tar.gz
gsoc2013-evolution-1997f5cf6d478f2c7162b1b80699b165d0161ddc.tar.bz2
gsoc2013-evolution-1997f5cf6d478f2c7162b1b80699b165d0161ddc.tar.lz
gsoc2013-evolution-1997f5cf6d478f2c7162b1b80699b165d0161ddc.tar.xz
gsoc2013-evolution-1997f5cf6d478f2c7162b1b80699b165d0161ddc.tar.zst
gsoc2013-evolution-1997f5cf6d478f2c7162b1b80699b165d0161ddc.zip
Fix champlain-gtk checks in configure.ac.
Check for champlain-gtk-0.8 not 0.5, and drop the fallback to 0.4.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 2 insertions, 5 deletions
diff --git a/configure.ac b/configure.ac
index 787f197e72..f083996c5e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1493,15 +1493,12 @@ if test "x$enable_plugins" = "xexperimental"; then
[enable_contacts_map="$enableval"], [enable_contacts_map=yes])
if test "x$enable_contacts_map" = "xyes"; then
- PKG_CHECK_MODULES([CHAMPLAIN], [champlain-gtk-0.5 >= champlain_minimum_version], [have_champlain=yes], [have_champlain=no])
- if test "x$have_champlain" = "xno"; then
- PKG_CHECK_MODULES([CHAMPLAIN], [champlain-gtk-0.4 >= champlain_minimum_version], [have_champlain=yes], [have_champlain=no])
- fi
+ PKG_CHECK_MODULES([CHAMPLAIN], [champlain-gtk-0.8 >= champlain_minimum_version], [have_champlain=yes], [have_champlain=no])
AC_SUBST(CHAMPLAIN_CFLAGS)
AC_SUBST(CHAMPLAIN_LIBS)
if test "x$have_champlain" = "xno"; then
- AC_MSG_ERROR([champlain-gtk >= champlain_minimum_version is required for the contacts-map plugin. Use --disable-contacts-map to exclude the plugin.])
+ AC_MSG_ERROR([champlain-gtk-0.8 >= champlain_minimum_version is required for the contacts-map plugin. Use --disable-contacts-map to exclude the plugin.])
fi
PKG_CHECK_MODULES([GEOCLUE], [geoclue >= geoclue_minimum_version], [have_geoclue=yes], [have_geoclue=no])