aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorMatthew Barnes <mbarnes@redhat.com>2012-06-19 08:57:25 +0800
committerMatthew Barnes <mbarnes@redhat.com>2012-06-19 09:08:35 +0800
commit0fdd38639fa1734b5fff24d9dbd34bb9e1492742 (patch)
tree8d8eecdf9e187664f26a4ba46512fc94b4560943 /configure.ac
parente9c96b8b790130deadc0fe88c1c18ba6355104e2 (diff)
downloadgsoc2013-evolution-0fdd38639fa1734b5fff24d9dbd34bb9e1492742.tar
gsoc2013-evolution-0fdd38639fa1734b5fff24d9dbd34bb9e1492742.tar.gz
gsoc2013-evolution-0fdd38639fa1734b5fff24d9dbd34bb9e1492742.tar.bz2
gsoc2013-evolution-0fdd38639fa1734b5fff24d9dbd34bb9e1492742.tar.lz
gsoc2013-evolution-0fdd38639fa1734b5fff24d9dbd34bb9e1492742.tar.xz
gsoc2013-evolution-0fdd38639fa1734b5fff24d9dbd34bb9e1492742.tar.zst
gsoc2013-evolution-0fdd38639fa1734b5fff24d9dbd34bb9e1492742.zip
Remove --enable-plugins=list variation.
With the removal of the 'experimental' plugin group, passing --enable-plugins=experimental to configure will now cause the Makefile to try and build a plugin named 'experimental', which will result in a mysterious "experimental: No such file or directory" build error. This is because of the "list" fallback behavior: if the option is not one of "no", "base" or "all" then the configure script assumes it to be a list of plugin names. I've never known that to be useful to anyone, so remove the "list of plugin names" behavior and replace it with an informative error message. Eventually the --enable-plugins will be removed entirely since EPlugin is deprecated.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 3 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 911a224f74..475c4ac236 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1224,7 +1224,7 @@ EVO_PLUGIN_RULE=$srcdir/plugin.mk
AC_SUBST_FILE(EVO_PLUGIN_RULE)
AC_ARG_ENABLE([plugins],
- AS_HELP_STRING([--enable-plugins=[no/base/all/list]],
+ AS_HELP_STRING([--enable-plugins=[no/base/all]],
[Enable plugins.]),
[enable_plugins="$enableval"],[enable_plugins=all])
@@ -1383,8 +1383,8 @@ xbase)
msg_plugins="yes ($plugins_base)"
;;
*)
- plugins_enabled="$enable_plugins"
- msg_plugins="yes ($enable_plugins)"
+ AC_MSG_ERROR([Invalid value for --enable-plugins.
+ Please specify either "no", "base", or "all" (default=all)])
;;
esac