aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorMatthew Barnes <mbarnes@redhat.com>2012-05-29 00:36:37 +0800
committerMatthew Barnes <mbarnes@redhat.com>2012-05-29 00:50:18 +0800
commit005ac1efa32c7e3a3dc5eb959b69fdee5fb91320 (patch)
treeb7eaca0fc61577360d34e35464465d7232e4b414 /configure.ac
parent2c9f0932e8c2bc100f8ec7335a20fbfecea052a2 (diff)
downloadgsoc2013-evolution-005ac1efa32c7e3a3dc5eb959b69fdee5fb91320.tar
gsoc2013-evolution-005ac1efa32c7e3a3dc5eb959b69fdee5fb91320.tar.gz
gsoc2013-evolution-005ac1efa32c7e3a3dc5eb959b69fdee5fb91320.tar.bz2
gsoc2013-evolution-005ac1efa32c7e3a3dc5eb959b69fdee5fb91320.tar.lz
gsoc2013-evolution-005ac1efa32c7e3a3dc5eb959b69fdee5fb91320.tar.xz
gsoc2013-evolution-005ac1efa32c7e3a3dc5eb959b69fdee5fb91320.tar.zst
gsoc2013-evolution-005ac1efa32c7e3a3dc5eb959b69fdee5fb91320.zip
Make the settings capplet optional.
The evolution-settings capplet was originally designed for Anjal, it was used in MeeGo as part of the Express Mode effort, but doesn't really fit in GNOME 3 nowadays (nor did it really fit in GNOME 2, in my opinion). Add a --with-capplet configure switch defaulting to 'no'. The capplet will eventually be removed unless I see someone actively maintaining it.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac14
1 files changed, 14 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index a9970d31e4..1eccf4fb40 100644
--- a/configure.ac
+++ b/configure.ac
@@ -305,6 +305,20 @@ AC_ARG_WITH([help],
AM_CONDITIONAL(WITH_HELP, test "x$with_help" != "xno")
AC_MSG_RESULT([$with_help])
+dnl ****************
+dnl Settings Capplet
+dnl ****************
+AC_MSG_CHECKING([whether to build the settings capplet])
+AC_ARG_WITH([capplet],
+ [AS_HELP_STRING([--with-capplet],
+ [Build the account settings capplet [default=no]])],
+ [with_capplet="$withval"],[with_capplet="no"])
+if test "x$with_capplet" = "xyes"; then
+ AC_DEFINE(WITH_CAPPLET, 1, [Define if building the settings capplet])
+fi
+AM_CONDITIONAL(WITH_CAPPLET, test "x$with_capplet" = "xyes")
+AC_MSG_RESULT([$with_capplet])
+
dnl ******************************
dnl iconv checking
dnl ******************************