aboutsummaryrefslogtreecommitdiffstats
path: root/camel/providers/mbox/Makefile.am
diff options
context:
space:
mode:
authorNotZed <notzed@zedzone.helixcode.com>2000-02-14 13:39:02 +0800
committerMichael Zucci <zucchi@src.gnome.org>2000-02-14 13:39:02 +0800
commitaeaa2ed70043e607e1da431d8f33726590f4c83b (patch)
tree6b017340f52b51b3eb55c0c847089ec5ca505263 /camel/providers/mbox/Makefile.am
parentddcfc699c72ee253307f2939492eb469beba3834 (diff)
downloadgsoc2013-evolution-aeaa2ed70043e607e1da431d8f33726590f4c83b.tar
gsoc2013-evolution-aeaa2ed70043e607e1da431d8f33726590f4c83b.tar.gz
gsoc2013-evolution-aeaa2ed70043e607e1da431d8f33726590f4c83b.tar.bz2
gsoc2013-evolution-aeaa2ed70043e607e1da431d8f33726590f4c83b.tar.lz
gsoc2013-evolution-aeaa2ed70043e607e1da431d8f33726590f4c83b.tar.xz
gsoc2013-evolution-aeaa2ed70043e607e1da431d8f33726590f4c83b.tar.zst
gsoc2013-evolution-aeaa2ed70043e607e1da431d8f33726590f4c83b.zip
New file, implements the search api for mbox folders.
2000-02-13 NotZed <notzed@zedzone.helixcode.com> * providers/mbox/camel-mbox-search.c: New file, implements the search api for mbox folders. * providers/mbox/Makefile.am: Link with ibex. * camel-folder.c (camel_folder_has_search_capability): Api additions. (camel_folder_search_by_expression): Ditto. 2000-02-12 NotZed <notzed@zedzone.helixcode.com> * providers/mbox/camel-mbox-folder.c (_set_name): Setup index filename as well. (_init_with_store): Init index filename. Hmm, none of these names ever seem to get free'd (FIXME?) * providers/mbox/camel-mbox-folder.h: Add index file name. 2000-02-12 NotZed <notzed@helixcode.com> * camel-folder.h: Add folder search functions. ** Created ChangeLog just for camel ** - refer to ../ChangeLog for changes prior to this date. svn path=/trunk/; revision=1772
Diffstat (limited to 'camel/providers/mbox/Makefile.am')
-rw-r--r--camel/providers/mbox/Makefile.am7
1 files changed, 6 insertions, 1 deletions
diff --git a/camel/providers/mbox/Makefile.am b/camel/providers/mbox/Makefile.am
index be8bce9232..9b5b40ff84 100644
--- a/camel/providers/mbox/Makefile.am
+++ b/camel/providers/mbox/Makefile.am
@@ -9,7 +9,8 @@ lib_LTLIBRARIES = libcamelmbox.la
INCLUDES = -I.. -I$(srcdir)/.. -I$(includedir) \
-I$(top_srcdir)/intl \
- $(GTK_INCLUDEDIR) -I$(top_srcdir)/camel
+ $(GTK_INCLUDEDIR) -I$(top_srcdir)/camel \
+ -I$(top_srcdir)/libibex
libcamelmbox_la_SOURCES = \
camel-mbox-folder.c \
@@ -17,6 +18,7 @@ libcamelmbox_la_SOURCES = \
camel-mbox-provider.c \
camel-mbox-store.c \
camel-mbox-summary.c \
+ camel-mbox-search.c \
camel-mbox-utils.c
libcamelmboxinclude_HEADERS = \
@@ -24,10 +26,13 @@ libcamelmboxinclude_HEADERS = \
camel-mbox-parser.h \
camel-mbox-store.h \
camel-mbox-summary.h \
+ camel-mbox-search.h \
camel-mbox-utils.h
libcamelmbox_la_LDFLAGS = -version-info 0:0:0 -rpath $(libdir)
+#libcamelmbox_la_LIBADD = -L$(top_srcdir)/libibex -libex
+libcamelmbox_la_LIBADD = $(top_srcdir)/libibex/libibex.la
EXTRA_DIST =