aboutsummaryrefslogtreecommitdiffstats
path: root/camel/providers/imap4/Makefile.am
diff options
context:
space:
mode:
authorJeffrey Stedfast <fejj@src.gnome.org>2004-03-25 06:11:05 +0800
committerJeffrey Stedfast <fejj@src.gnome.org>2004-03-25 06:11:05 +0800
commit2ac983181ab03ef7f71cba91201c2d88add302b0 (patch)
treee1e2c971936b06ee28099e93d18c47f083f96202 /camel/providers/imap4/Makefile.am
parent928067b4e75f1d23519e8608d5765a2a2b5d441c (diff)
downloadgsoc2013-evolution-2ac983181ab03ef7f71cba91201c2d88add302b0.tar
gsoc2013-evolution-2ac983181ab03ef7f71cba91201c2d88add302b0.tar.gz
gsoc2013-evolution-2ac983181ab03ef7f71cba91201c2d88add302b0.tar.bz2
gsoc2013-evolution-2ac983181ab03ef7f71cba91201c2d88add302b0.tar.lz
gsoc2013-evolution-2ac983181ab03ef7f71cba91201c2d88add302b0.tar.xz
gsoc2013-evolution-2ac983181ab03ef7f71cba91201c2d88add302b0.tar.zst
gsoc2013-evolution-2ac983181ab03ef7f71cba91201c2d88add302b0.zip
The beginnings of a new IMAP provider module
svn path=/trunk/; revision=25176
Diffstat (limited to 'camel/providers/imap4/Makefile.am')
-rw-r--r--camel/providers/imap4/Makefile.am33
1 files changed, 33 insertions, 0 deletions
diff --git a/camel/providers/imap4/Makefile.am b/camel/providers/imap4/Makefile.am
new file mode 100644
index 0000000000..c07f943e84
--- /dev/null
+++ b/camel/providers/imap4/Makefile.am
@@ -0,0 +1,33 @@
+## Process this file with automake to produce Makefile.in
+
+libcamelimap4includedir = $(privincludedir)/camel
+
+camel_provider_LTLIBRARIES = libcamelimap4.la
+camel_provider_DATA = libcamelimap4.urls
+
+INCLUDES = \
+ -I$(top_srcdir) \
+ -I$(top_srcdir)/camel \
+ -I$(top_srcdir)/intl \
+ -I$(top_srcdir)/e-util \
+ -I$(top_srcdir) \
+ $(CAMEL_CFLAGS) \
+ $(GNOME_INCLUDEDIR) \
+ $(GTK_INCLUDEDIR) \
+ -DG_LOG_DOMAIN=\"camel-imap4-provider\"
+
+libcamelimap4_la_SOURCES = \
+ camel-imap-command.c \
+ camel-imap-command.h \
+ camel-imap-engine.c \
+ camel-imap-engine.h \
+ camel-imap-specials.c \
+ camel-imap-specials.h \
+ camel-imap-stream.c \
+ camel-imap-stream.h \
+ camel-imap-utils.c \
+ camel-imap-utils.h
+
+libcamelimap4_la_LDFLAGS = -avoid-version -module
+
+EXTRA_DIST = libcamelimap4.urls