aboutsummaryrefslogtreecommitdiffstats
path: root/camel/providers/groupwise/Makefile.am
diff options
context:
space:
mode:
authorRodrigo Moya <rodrigo@ximian.com>2003-12-25 00:29:42 +0800
committerRodrigo Moya <rodrigo@src.gnome.org>2003-12-25 00:29:42 +0800
commit978af43d69587e93fba2e861e9fa33ffa198b0e0 (patch)
tree6ace8a385eae0c3e72b35022ec59f6dbf23b48cb /camel/providers/groupwise/Makefile.am
parent9f2fcb717fc961c2f5c3f5abf559a1637206c188 (diff)
downloadgsoc2013-evolution-978af43d69587e93fba2e861e9fa33ffa198b0e0.tar
gsoc2013-evolution-978af43d69587e93fba2e861e9fa33ffa198b0e0.tar.gz
gsoc2013-evolution-978af43d69587e93fba2e861e9fa33ffa198b0e0.tar.bz2
gsoc2013-evolution-978af43d69587e93fba2e861e9fa33ffa198b0e0.tar.lz
gsoc2013-evolution-978af43d69587e93fba2e861e9fa33ffa198b0e0.tar.xz
gsoc2013-evolution-978af43d69587e93fba2e861e9fa33ffa198b0e0.tar.zst
gsoc2013-evolution-978af43d69587e93fba2e861e9fa33ffa198b0e0.zip
g_module_open the other providers we depend on to avoid load ordering
2003-12-24 Rodrigo Moya <rodrigo@ximian.com> * providers/groupwise/camel-groupwise-provider.c (camel_provider_module_init): g_module_open the other providers we depend on to avoid load ordering problems. 2003-12-22 Rodrigo Moya <rodrigo@ximian.com> * providers/groupwise/camel-groupwise-provider.c: removed useless configuration options, and added other options from the IMAP provider. (camel_provider_module_init): register a SMTP transport object also, and removed SASL registration, since we don't support it. 2003-12-19 Sivaiah Nallagatla <snallagatla@novell.com> * providers/groupwise/Makefile.am: * providers/groupwise/libcamelgroupwise.urls: * providers/groupwise/camel-groupwise-provider.c: added Camel provider for Groupwise accounts, based on the IMAP one. svn path=/trunk/; revision=24008
Diffstat (limited to 'camel/providers/groupwise/Makefile.am')
-rw-r--r--camel/providers/groupwise/Makefile.am32
1 files changed, 32 insertions, 0 deletions
diff --git a/camel/providers/groupwise/Makefile.am b/camel/providers/groupwise/Makefile.am
new file mode 100644
index 0000000000..a8eca01d1c
--- /dev/null
+++ b/camel/providers/groupwise/Makefile.am
@@ -0,0 +1,32 @@
+## Process this file with automake to produce Makefile.in
+
+libcamelimapincludedir = $(privincludedir)/camel
+
+camel_provider_LTLIBRARIES = libcamelgroupwise.la
+camel_provider_DATA = libcamelgroupwise.urls
+
+INCLUDES = -I.. \
+ -I$(srcdir)/.. \
+ -I$(top_srcdir)/camel \
+ -I$(top_srcdir)/intl \
+ -I$(top_srcdir)/e-util \
+ -I$(top_srcdir) \
+ -I$(top_srcdir)/camel/providers/imap \
+ -I$(top_srcdir)/camel/providers/smtp \
+ $(CAMEL_CFLAGS) \
+ $(GNOME_INCLUDEDIR) \
+ $(GTK_INCLUDEDIR) \
+ -DCAMEL_PROVIDERDIR=\"$(camel_providerdir)\" \
+ -DG_LOG_DOMAIN=\"camel-groupwise-provider\"
+
+libcamelgroupwise_la_SOURCES = \
+ camel-groupwise-provider.c
+
+libcamelgroupwise_la_LDFLAGS = -avoid-version -module
+
+# libcamelgroupwise_la_LIBADD =
+# $(top_builddir)/camel/providers/imap/libcamelimap.la \
+# $(top_builddir)/camel/providers/smtp/libcamelsmtp.la
+
+
+EXTRA_DIST = libcamelimap.urls