aboutsummaryrefslogtreecommitdiffstats
path: root/calendar/gui/Makefile.am
diff options
context:
space:
mode:
authorJP Rosevear <jpr@ximian.com>2002-05-27 00:21:28 +0800
committerJP Rosevear <jpr@src.gnome.org>2002-05-27 00:21:28 +0800
commitfb1d17d150cb5178ca1d63431958d3df9dfc60b3 (patch)
tree5c17aae3a1d8b6a5d52909a30bcc5391c03f465f /calendar/gui/Makefile.am
parente6298a6cd5faa861d4185c1399fe627e6d70d8f8 (diff)
downloadgsoc2013-evolution-fb1d17d150cb5178ca1d63431958d3df9dfc60b3.tar
gsoc2013-evolution-fb1d17d150cb5178ca1d63431958d3df9dfc60b3.tar.gz
gsoc2013-evolution-fb1d17d150cb5178ca1d63431958d3df9dfc60b3.tar.bz2
gsoc2013-evolution-fb1d17d150cb5178ca1d63431958d3df9dfc60b3.tar.lz
gsoc2013-evolution-fb1d17d150cb5178ca1d63431958d3df9dfc60b3.tar.xz
gsoc2013-evolution-fb1d17d150cb5178ca1d63431958d3df9dfc60b3.tar.zst
gsoc2013-evolution-fb1d17d150cb5178ca1d63431958d3df9dfc60b3.zip
a registry of comp editors so we can close them all centrally
2002-05-26 JP Rosevear <jpr@ximian.com> * gui/e-comp-editor-registry.[hc]: a registry of comp editors so we can close them all centrally * gui/gnome-cal.c (gnome_calendar_init): there is no editor hash now (gnome_calendar_destroy): ditto (gnome_calendar_edit_object): look for the event editor in the registry, if it isn't there, create it and add it to the registry * gui/e-calendar-table.c (open_task): look for the task editor in the registry, if it isn't there, create it and add it to the registry * gui/component-factory.c (request_quit): close all open editors (create_object): add a request_quit function to the shell component * gui/comp-editor-factory.c (free_client): there is no uid_comp_hash to free any more (editor_destroy_cb): we get an OpenClient as callback data now, reduce the editor count and destroy it if it is 0 (edit_existing): don't create the Component, add the new editor to the registry, increase the editor count (edit_new): ditto (open_client): set the editor count to 0 (impl_editExisting): look in the registry for the editor * gui/Makefile.am: Build new sources * gui/main.c (main): create the registry * gui/dialogs/comp-editor.c (comp_editor_close): prompt to save and then close dialog * gui/dialogs/comp-editor.h: new proto * gui/GNOME_Evolution_Calendar.oaf.in: remove dead summary stuff svn path=/trunk/; revision=17018
Diffstat (limited to 'calendar/gui/Makefile.am')
-rw-r--r--calendar/gui/Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/calendar/gui/Makefile.am b/calendar/gui/Makefile.am
index 20e2207907..9c842635f7 100644
--- a/calendar/gui/Makefile.am
+++ b/calendar/gui/Makefile.am
@@ -97,6 +97,8 @@ evolution_calendar_SOURCES = \
e-calendar-table.c \
e-cell-date-edit-text.h \
e-cell-date-edit-text.c \
+ e-comp-editor-registry.c \
+ e-comp-editor-registry.h \
e-day-view-layout.c \
e-day-view-layout.h \
e-day-view-main-item.c \