aboutsummaryrefslogtreecommitdiffstats
path: root/calendar/gui/Makefile.am
diff options
context:
space:
mode:
authorFederico Mena Quintero <federico@ximian.com>2001-05-17 07:38:58 +0800
committerFederico Mena Quintero <federico@src.gnome.org>2001-05-17 07:38:58 +0800
commitf00e9367382fb81cdb4b689f96645357f122b051 (patch)
tree1750ce1d4c5104dd77a2d509bd00ca657915ebae /calendar/gui/Makefile.am
parentd0243a91821d311699347c11d454314bdbdfc0fe (diff)
downloadgsoc2013-evolution-f00e9367382fb81cdb4b689f96645357f122b051.tar
gsoc2013-evolution-f00e9367382fb81cdb4b689f96645357f122b051.tar.gz
gsoc2013-evolution-f00e9367382fb81cdb4b689f96645357f122b051.tar.bz2
gsoc2013-evolution-f00e9367382fb81cdb4b689f96645357f122b051.tar.lz
gsoc2013-evolution-f00e9367382fb81cdb4b689f96645357f122b051.tar.xz
gsoc2013-evolution-f00e9367382fb81cdb4b689f96645357f122b051.tar.zst
gsoc2013-evolution-f00e9367382fb81cdb4b689f96645357f122b051.zip
Split the event and task editors into different objects for the separate
2001-05-16 Federico Mena Quintero <federico@ximian.com> Split the event and task editors into different objects for the separate pages; this way they can be shared by both editors. * gui/dialogs/editor-page.[ch]: New abstract class for a page in a calendar component editor. * gui/dialogs/event-page.[ch]: Main page of an event editor. * gui/dialogs/alarm-page.[ch]: Alarm page of a calendar component editor. * gui/dialogs/recurrence-page.[ch]: Recurrence page of a calendar component editor. * gui/dialogs/event-page.c (event_page_fill_widgets): Eeek, this was missing a bunch of break statements. (event_page_fill_component): Use a temporary variable rather than allocating a struct icaltimetype. * gui/dialogs/alarm-page.c (get_alarm_string): Do not use fixed-size buffers. (alarm_page_fill_widgets): Use cal_obj_uid_list_free(). (append_reminder): Now the list stores the plain CalComponentAlarm structures in the row data. We do *NOT* want to be frobbing the component's data directly. Rather, we clone the alarms from the component and maintain them on our own. (alarm_page_fill_component): Clone the alarms before adding them to the component so that we maintain the invariant that the alarm structures in the list did *not* come from the component. * cal-util/cal-component.c (cal_component_add_alarm): Added documentation. (cal_component_remove_alarm): Added documentation. (cal_component_remove_alarm): Do a lookup in our hash table of alarms instead of scanning the whole component. (CalComponentAlarm): Removed the `parent' field, since it was unused. (cal_component_free_alarm_uids): Removed function, since cal_component_get_alarm_uids() is documented so that the user will know that he must use cal_obj_uid_list_free(). (cal_component_alarm_clone): New function. svn path=/trunk/; revision=9861
Diffstat (limited to 'calendar/gui/Makefile.am')
-rw-r--r--calendar/gui/Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/calendar/gui/Makefile.am b/calendar/gui/Makefile.am
index 292e1ebd28..8cd202c7c0 100644
--- a/calendar/gui/Makefile.am
+++ b/calendar/gui/Makefile.am
@@ -87,6 +87,8 @@ evolution_calendar_SOURCES = \
e-week-view.h \
e-tasks.c \
e-tasks.h \
+ editor-page.c \
+ editor-page.h \
event-editor.c \
event-editor.h \
gnome-cal.c \