aboutsummaryrefslogtreecommitdiffstats
path: root/calendar/gui/Makefile.am
diff options
context:
space:
mode:
authorBolian Yin <bolian.yin@sun.com>2003-08-20 16:05:00 +0800
committerBolian Yin <byin@src.gnome.org>2003-08-20 16:05:00 +0800
commitef5eb5facdf293531569ca1d8b7ab7fd976fbe83 (patch)
tree5f8bce18e4c7ee5d6e31878b29facad4841f12f5 /calendar/gui/Makefile.am
parent7bb25afd430ffab77397d9fc4e6b756251ba31d8 (diff)
downloadgsoc2013-evolution-ef5eb5facdf293531569ca1d8b7ab7fd976fbe83.tar
gsoc2013-evolution-ef5eb5facdf293531569ca1d8b7ab7fd976fbe83.tar.gz
gsoc2013-evolution-ef5eb5facdf293531569ca1d8b7ab7fd976fbe83.tar.bz2
gsoc2013-evolution-ef5eb5facdf293531569ca1d8b7ab7fd976fbe83.tar.lz
gsoc2013-evolution-ef5eb5facdf293531569ca1d8b7ab7fd976fbe83.tar.xz
gsoc2013-evolution-ef5eb5facdf293531569ca1d8b7ab7fd976fbe83.tar.zst
gsoc2013-evolution-ef5eb5facdf293531569ca1d8b7ab7fd976fbe83.zip
Add a11y dependency. gui/calendar-commands.c
2003-08-20 Bolian Yin <bolian.yin@sun.com> * gui/Makefile.am : Add a11y dependency. * gui/calendar-commands.c (calendar_get_text_for_folder_bar_label) * gui/e-cal-view.c: Add two new events: "event_changed" and "event_added" * gui/e-day-view.c (e_day_view_class_init): init a11y. (e_day_view_find_event_from_item): make it public from private (e_day_view_update_event_cb): emit "event_changed" signal (e_day_view_reshape_day_event): emit "event_added" signal (e_day_view_reshape_long_event): emit "event_added" signal * gui/e-week-view.c (e_week_view_class_init): init a11y. (e_week_view_find_event_from_item): make it public from private (e_week_view_update_event_cb): emit "event_changed" signal (e_week_view_reshape_event_span): emit "event_added" signal * gui/gnome-cal.c (gnome_calendar_class_init): init a11y. (gnome_calendar_get_e_calendar_widget), (gnome_calendar_get_search_bar_widget), (gnome_calendar_get_view_notebook_widget): new functions svn path=/trunk/; revision=22303
Diffstat (limited to 'calendar/gui/Makefile.am')
-rw-r--r--calendar/gui/Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/calendar/gui/Makefile.am b/calendar/gui/Makefile.am
index eef7821858..ec37100bb0 100644
--- a/calendar/gui/Makefile.am
+++ b/calendar/gui/Makefile.am
@@ -73,6 +73,7 @@ INCLUDES = \
-I$(top_srcdir)/addressbook/backend \
-I$(top_builddir)/addressbook/backend \
-I$(top_srcdir)/widgets \
+ -I$(top_srcdir)/a11y/calendar \
-DEVOLUTION_DATADIR=\""$(datadir)"\" \
-DEVOLUTION_GLADEDIR=\""$(gladedir)"\" \
-DEVOLUTION_ETSPECDIR=\""$(etspecdir)"\" \
@@ -194,6 +195,7 @@ libevolution_calendar_la_LIBADD = \
$(top_builddir)/calendar/gui/dialogs/libcal-dialogs.la \
$(top_builddir)/widgets/e-timezone-dialog/libetimezonedialog.la \
$(top_builddir)/widgets/misc/libemiscwidgets.la \
+ $(top_builddir)/a11y/libevolution-a11y.la \
$(EVOLUTION_CALENDAR_LIBS)
libevolution_calendar_la_LDFLAGS = -avoid-version -module