aboutsummaryrefslogtreecommitdiffstats
path: root/calendar/gui/Makefile.am
diff options
context:
space:
mode:
authorJP Rosevear <jpr@ximian.com>2003-10-31 21:28:44 +0800
committerJP Rosevear <jpr@src.gnome.org>2003-10-31 21:28:44 +0800
commitbdf19d320404cc3c0aa6900ea711279f80ceab6a (patch)
tree344bc87daad354aa5ae91ce9e2b9a018d137d7a8 /calendar/gui/Makefile.am
parent318ff6a39433c962150b5bd78e2bd13de7b637d8 (diff)
downloadgsoc2013-evolution-bdf19d320404cc3c0aa6900ea711279f80ceab6a.tar
gsoc2013-evolution-bdf19d320404cc3c0aa6900ea711279f80ceab6a.tar.gz
gsoc2013-evolution-bdf19d320404cc3c0aa6900ea711279f80ceab6a.tar.bz2
gsoc2013-evolution-bdf19d320404cc3c0aa6900ea711279f80ceab6a.tar.lz
gsoc2013-evolution-bdf19d320404cc3c0aa6900ea711279f80ceab6a.tar.xz
gsoc2013-evolution-bdf19d320404cc3c0aa6900ea711279f80ceab6a.tar.zst
gsoc2013-evolution-bdf19d320404cc3c0aa6900ea711279f80ceab6a.zip
set up vars and rules for versioning the .server files
2003-10-31 JP Rosevear <jpr@ximian.com> * configure.in: set up vars and rules for versioning the .server files * Makefile.am's: use rules for versioning .server file, ensure built files are removed before disting svn path=/trunk/; revision=23149
Diffstat (limited to 'calendar/gui/Makefile.am')
-rw-r--r--calendar/gui/Makefile.am10
1 files changed, 4 insertions, 6 deletions
diff --git a/calendar/gui/Makefile.am b/calendar/gui/Makefile.am
index 876834bfcb..ae623b84db 100644
--- a/calendar/gui/Makefile.am
+++ b/calendar/gui/Makefile.am
@@ -215,18 +215,16 @@ libevolution_calendar_la_LIBADD = \
libevolution_calendar_la_LDFLAGS = -avoid-version -module
server_in_files = GNOME_Evolution_Calendar.server.in.in
-
-server_DATA = $(server_in_files:.server.in.in=.server)
-%.server.in: %.server.in.in
- sed -e "s|\@COMPONENTDIR\@|$(componentdir)|" $< > $@
+server_DATA = $(server_in_files:.server.in.in=_$(BASE_VERSION).server)
+@EVO_SUBST_SERVER_RULE@
+@EVO_NAME_SERVER_RULE@
+@INTLTOOL_SERVER_RULE@
# GConf schemas
schemadir = $(GCONF_SCHEMA_FILE_DIR)
schema_DATA = apps_evolution_calendar.schemas
-@INTLTOOL_SERVER_RULE@
-
EXTRA_DIST = \
$(glade_DATA) \
$(schema_DATA) \