aboutsummaryrefslogtreecommitdiffstats
path: root/calendar/gui/Makefile.am
diff options
context:
space:
mode:
authorDamon Chaplin <damon@helixcode.com>2001-01-08 08:47:35 +0800
committerDamon Chaplin <damon@src.gnome.org>2001-01-08 08:47:35 +0800
commita223b88a9034f0c33f2e979403e1352ff822f8a2 (patch)
tree180ec792800fb8d2468fb2ae6829b5c87cc7f5f8 /calendar/gui/Makefile.am
parent45b8f9d767b5a178e0fdcb48901e664334fd8183 (diff)
downloadgsoc2013-evolution-a223b88a9034f0c33f2e979403e1352ff822f8a2.tar
gsoc2013-evolution-a223b88a9034f0c33f2e979403e1352ff822f8a2.tar.gz
gsoc2013-evolution-a223b88a9034f0c33f2e979403e1352ff822f8a2.tar.bz2
gsoc2013-evolution-a223b88a9034f0c33f2e979403e1352ff822f8a2.tar.lz
gsoc2013-evolution-a223b88a9034f0c33f2e979403e1352ff822f8a2.tar.xz
gsoc2013-evolution-a223b88a9034f0c33f2e979403e1352ff822f8a2.tar.zst
gsoc2013-evolution-a223b88a9034f0c33f2e979403e1352ff822f8a2.zip
added new source files for the Tasks folders.
2001-01-08 Damon Chaplin <damon@helixcode.com> * gui/Makefile.am: added new source files for the Tasks folders. * gui/e-tasks.[hc]: new widget to encapsulate the Tasks view. * gui/tasks-control.[hc]: new files to implement the Tasks control. * gui/tasks-control-factory.[hc]: new files to implement the factory for the Tasks controls. (I think the way I've split the code up is a lot cleaner than the GnomeCal implementation - the factory file just contains the factory functions and the control file contains all the control functions. Maybe we should make GnomeCal like this.) * gui/main.c: initialize the Tasks control factory. * gui/component-factory.c: added support for the Tasks control. Also added a "create_folder" function so we can now create new Tasks and Calendar folders within Evolution. I'm not a Bonobo expert so someone might want to check these over. * gui/calendar-config.[hc]: added convenience functions to configure the common settings of ECalendar and EDateEdit widgets. * gui/dialogs/task-editor.c (task_editor_create_date_edit): * gui/gnome-cal.c (gnome_calendar_update_config_settings): * gui/event-editor.c: used function to configure the ECalendars and EDateEdits. * gui/e-day-view-top-item.c (e_day_view_top_item_draw_long_event): fixed minor bug in format strings. svn path=/trunk/; revision=7297
Diffstat (limited to 'calendar/gui/Makefile.am')
-rw-r--r--calendar/gui/Makefile.am6
1 files changed, 6 insertions, 0 deletions
diff --git a/calendar/gui/Makefile.am b/calendar/gui/Makefile.am
index db2da7da5d..e10c6f8cc5 100644
--- a/calendar/gui/Makefile.am
+++ b/calendar/gui/Makefile.am
@@ -105,6 +105,8 @@ evolution_calendar_SOURCES = \
e-week-view-titles-item.h \
e-week-view.c \
e-week-view.h \
+ e-tasks.c \
+ e-tasks.h \
event-editor.c \
event-editor.h \
gnome-cal.c \
@@ -122,6 +124,10 @@ evolution_calendar_SOURCES = \
print.h \
tag-calendar.c \
tag-calendar.h \
+ tasks-control-factory.c \
+ tasks-control-factory.h \
+ tasks-control.c \
+ tasks-control.h \
weekday-picker.c \
weekday-picker.h \
widget-util.c \