aboutsummaryrefslogtreecommitdiffstats
path: root/calendar/gui/Makefile.am
diff options
context:
space:
mode:
authorFederico Mena Quintero <federico@helixcode.com>2000-12-15 19:39:48 +0800
committerFederico Mena Quintero <federico@src.gnome.org>2000-12-15 19:39:48 +0800
commit937d719a6a5b880df4b75cfe8318d37fd4a4e814 (patch)
tree6185ecc76c9e1f333d47d2d35dbb8c91021d3fea /calendar/gui/Makefile.am
parent5674d76445b199855d4d431b6db4c0302f4a932b (diff)
downloadgsoc2013-evolution-937d719a6a5b880df4b75cfe8318d37fd4a4e814.tar
gsoc2013-evolution-937d719a6a5b880df4b75cfe8318d37fd4a4e814.tar.gz
gsoc2013-evolution-937d719a6a5b880df4b75cfe8318d37fd4a4e814.tar.bz2
gsoc2013-evolution-937d719a6a5b880df4b75cfe8318d37fd4a4e814.tar.lz
gsoc2013-evolution-937d719a6a5b880df4b75cfe8318d37fd4a4e814.tar.xz
gsoc2013-evolution-937d719a6a5b880df4b75cfe8318d37fd4a4e814.tar.zst
gsoc2013-evolution-937d719a6a5b880df4b75cfe8318d37fd4a4e814.zip
Fixes bug #955.
2000-12-14 Federico Mena Quintero <federico@helixcode.com> Fixes bug #955. * gui/weekday-picker.c (WeekdayPickerPrivate): Added a field for the week_start_day, to be used in the same way as calendar-config.h defines it. Removed the week_starts_on_monday flag. (day_event_cb): Use the week_start_day. (colorize_items): Likewise. (configure_items): Likewise. (weekday_picker_set_week_start_day): New function. (weekday_picker_get_week_start_day): New function. (weekday_picker_set_week_starts_on_monday): Removed function. (weekday_picker_get_week_starts_on_monday): Removed function. * gui/widget-util.[ch]: New files with utilities for creating or configuring widgets. * gui/widget-util.c (date_edit_new): New function to create an EDateEdit configured with the calendar's preferences; moved over from event-editor.c. * gui/event-editor.c (make_recur_weekly_special): Use weekday_picker_set_week_start_day() and the corresponding function from calendar-config.h. (init_widgets): Likewise. (make_date_edit_with_time): Removed function. (make_recur_ending_until_special): Use date_edit_new(). (make_date_edit): Likewise. * gui/dialogs/task-editor.c (task_editor_create_date_edit): Likewise. * gui/event-editor-dialog.glade: Removed references to make_date_edit_with_time(); replace them with make_date_edit(). * gui/Makefile.am (evolution_calendar_SOURCES): Added widget-util.[ch] to the list of sources. svn path=/trunk/; revision=7037
Diffstat (limited to 'calendar/gui/Makefile.am')
-rw-r--r--calendar/gui/Makefile.am4
1 files changed, 3 insertions, 1 deletions
diff --git a/calendar/gui/Makefile.am b/calendar/gui/Makefile.am
index 2268fa2b3c..32cb4df91f 100644
--- a/calendar/gui/Makefile.am
+++ b/calendar/gui/Makefile.am
@@ -116,7 +116,9 @@ evolution_calendar_SOURCES = \
tag-calendar.c \
tag-calendar.h \
weekday-picker.c \
- weekday-picker.h
+ weekday-picker.h \
+ widget-util.c \
+ widget-util.h
evolution_calendar_LDADD = \
$(top_builddir)/shell/libeshell.a \