aboutsummaryrefslogtreecommitdiffstats
path: root/calendar/gui/Makefile.am
diff options
context:
space:
mode:
authorSeth Alves <alves@src.gnome.org>2000-06-29 21:23:44 +0800
committerSeth Alves <alves@src.gnome.org>2000-06-29 21:23:44 +0800
commit70c974e7d9d44db682cd9cc447485f292ad2aa54 (patch)
tree83d68fc016f555e36e8fa010d1f8b2367307fff3 /calendar/gui/Makefile.am
parentfe1bb9d0b60ab6a1b8a8c525d28d0b09d2d74641 (diff)
downloadgsoc2013-evolution-70c974e7d9d44db682cd9cc447485f292ad2aa54.tar
gsoc2013-evolution-70c974e7d9d44db682cd9cc447485f292ad2aa54.tar.gz
gsoc2013-evolution-70c974e7d9d44db682cd9cc447485f292ad2aa54.tar.bz2
gsoc2013-evolution-70c974e7d9d44db682cd9cc447485f292ad2aa54.tar.lz
gsoc2013-evolution-70c974e7d9d44db682cd9cc447485f292ad2aa54.tar.xz
gsoc2013-evolution-70c974e7d9d44db682cd9cc447485f292ad2aa54.tar.zst
gsoc2013-evolution-70c974e7d9d44db682cd9cc447485f292ad2aa54.zip
server code to service these:
* pcs/cal.c (Cal_get_uid_by_pilot_id): (Cal_update_pilot_id): * pcs/cal-backend-imc.c (cal_backend_imc_update_pilot_id): (cal_backend_imc_get_uid_by_pilot_id): * pcs/cal-backend.c (cal_backend_get_uid_by_pilot_id): (cal_backend_update_pilot_id): server code to service these: * gui/calendar-pilot-sync.c: updated to make use of cal-client. also uses dirty bits on both sides to aid in syncing. * cal-client/cal-client.c (cal_client_get_uid_by_pilot_id): new function -- ask the cal server to return uid given an object's pilot id. (cal_client_update_pilot_id): new function -- inform the cal server of an objects pilot id and pilot dirty-flag. svn path=/trunk/; revision=3789
Diffstat (limited to 'calendar/gui/Makefile.am')
-rw-r--r--calendar/gui/Makefile.am27
1 files changed, 26 insertions, 1 deletions
diff --git a/calendar/gui/Makefile.am b/calendar/gui/Makefile.am
index 5920d2112e..b7c6082f99 100644
--- a/calendar/gui/Makefile.am
+++ b/calendar/gui/Makefile.am
@@ -40,7 +40,8 @@ glade_DATA = \
glade_messages = event-editor-dialog.glade.h
-bin_PROGRAMS = evolution-calendar
+bin_PROGRAMS = evolution-calendar calendar-pilot-sync #empty-pilot-calendar
+# calendar-conduit-control-applet
evolution_calendar_SOURCES = \
alarm.c \
@@ -101,6 +102,30 @@ evolution_calendar_LDADD = \
evolution_calendar_LDFLAGS = `gnome-config --libs gdk_pixbuf`
+
+calendar_pilot_sync_SOURCES = \
+ calendar-pilot-sync.c
+
+calendar_pilot_sync_LDADD = -lpisock \
+ $(EXTRA_GNOME_LIBS) \
+ $(BONOBO_HTML_GNOME_LIBS) \
+ $(LINK_FLAGS)
+
+
+#empty_pilot_calendar_SOURCES = \
+# empty-pilot-calendar.c
+
+#empty_pilot_calendar_LDADD = -lpisock \
+# $(EXTRA_GNOME_LIBS) \
+# $(BONOBO_HTML_GNOME_LIBS) \
+# $(LINK_FLAGS)
+
+
+#calendar_pilot_sync_LDADD = \
+# $(PISOCK_LIBDIR) $(PISOCK_LIBS) \
+# $(LINK_FLAGS)
+
+
if USING_OAF
oafdir = $(datadir)/oaf
oaf_DATA = calendar-control.oafinfo evolution-calendar.oafinfo