aboutsummaryrefslogtreecommitdiffstats
path: root/calendar/gui/Makefile.am
diff options
context:
space:
mode:
authorSeth Alves <alves@src.gnome.org>2000-07-11 06:36:06 +0800
committerSeth Alves <alves@src.gnome.org>2000-07-11 06:36:06 +0800
commit10c3eb46b17f52a04eea878d2a701e91ab4f464e (patch)
tree7eb8af23f5641cbd1a6d8da413937e28d5ea2f86 /calendar/gui/Makefile.am
parent52d48e02c187b07a5fa29bbeb5359052fcde4e55 (diff)
downloadgsoc2013-evolution-10c3eb46b17f52a04eea878d2a701e91ab4f464e.tar
gsoc2013-evolution-10c3eb46b17f52a04eea878d2a701e91ab4f464e.tar.gz
gsoc2013-evolution-10c3eb46b17f52a04eea878d2a701e91ab4f464e.tar.bz2
gsoc2013-evolution-10c3eb46b17f52a04eea878d2a701e91ab4f464e.tar.lz
gsoc2013-evolution-10c3eb46b17f52a04eea878d2a701e91ab4f464e.tar.xz
gsoc2013-evolution-10c3eb46b17f52a04eea878d2a701e91ab4f464e.tar.zst
gsoc2013-evolution-10c3eb46b17f52a04eea878d2a701e91ab4f464e.zip
added makefiles for calendar conduits
* configure.in: added makefiles for calendar conduits * gui/Makefile.am (SUBDIRS): * conduits/calendar/Makefile.am: moved calendar-conduit stuff from the gui directory to here. * Makefile.am (SUBDIRS): added conduits to SIBDIRS svn path=/trunk/; revision=4058
Diffstat (limited to 'calendar/gui/Makefile.am')
-rw-r--r--calendar/gui/Makefile.am57
1 files changed, 28 insertions, 29 deletions
diff --git a/calendar/gui/Makefile.am b/calendar/gui/Makefile.am
index 969fd2e3ac..586a39139d 100644
--- a/calendar/gui/Makefile.am
+++ b/calendar/gui/Makefile.am
@@ -2,14 +2,13 @@ SUBDIRS = dialogs
help_base = $(datadir)/gnome/help/cal
-# if HAVE_GNOME_PILOT
-#CPS = calendar-pilot-sync #empty-pilot-calendar
-# else
-#CPS =
-# endif
+if HAVE_GNOME_PILOT
+CPS = calendar-pilot-sync
+else
+CPS =
+endif
-# bin_PROGRAMS = evolution-calendar $(CPS)
-bin_PROGRAMS = evolution-calendar
+bin_PROGRAMS = evolution-calendar $(CPS)
CPPFLAGS = \
-DEVOLUTION_GLADEDIR=\""$(gladedir)"\"
@@ -47,8 +46,6 @@ glade_DATA = \
glade_messages = event-editor-dialog.glade.h
-# calendar-conduit-control-applet
-
evolution_calendar_SOURCES = \
alarm.c \
alarm.h \
@@ -107,25 +104,25 @@ evolution_calendar_LDADD = \
evolution_calendar_LDFLAGS = `gnome-config --libs gdk_pixbuf`
-# if HAVE_GNOME_PILOT
-
-# calendar_pilot_sync_SOURCES = \
-# calendar-pilot-sync.c
-#
-# calendar_pilot_sync_INCLUDES = \
-# $(INCLUDES) \
-# $(GNOME_PILOT_CFLAGS) \
-# $(PISOCK_INCLUDEDIR) \
-# $(GNOME_CONDUIT_INCLUDEDIR)
-#
-# calendar_pilot_sync_LDADD = -lpisock \
-# $(BONOBO_VFS_GNOME_LIBS) \
-# $(LINK_FLAGS) \
-# $(EXTRA_GNOME_LIBS) \
-# $(BONOBO_HTML_GNOME_LIBS) \
-# $(GNOME_PILOT_LIBS) \
-# $(PISOCK_LIBS)
-# endif
+if HAVE_GNOME_PILOT
+calendar_pilot_sync_SOURCES = \
+ calendar-pilot-sync.c
+
+calendar_pilot_sync_INCLUDES = \
+ $(INCLUDES) \
+ $(GNOME_PILOT_CFLAGS) \
+ $(PISOCK_INCLUDEDIR) \
+ $(GNOME_CONDUIT_INCLUDEDIR)
+
+calendar_pilot_sync_LDADD = -lpisock \
+ $(BONOBO_VFS_GNOME_LIBS) \
+ $(LINK_FLAGS) \
+ $(EXTRA_GNOME_LIBS) \
+ $(BONOBO_HTML_GNOME_LIBS) \
+ $(GNOME_PILOT_LIBS) \
+ $(PISOCK_LIBS)
+endif
+
if USING_OAF
oafdir = $(datadir)/oaf
@@ -148,11 +145,13 @@ EXTRA_DIST = \
monthview.xpm \
yearview.xpm \
calendar-control.gnorba \
- calendar-control.oafinfo
+ calendar-control.oafinfo \
+ gnomecal.conduit
install-data-local:
$(mkinstalldirs) $(DESTDIR)$(help_base)/C
+ $(mkinstalldirs) $(Conduitsdir)
if ENABLE_PURIFY
PLINK = $(LIBTOOL) --mode=link $(PURIFY) $(CCLD) $(AM_CFLAGS) $(CFLAGS) $(LDFLAGS) -o $@