aboutsummaryrefslogtreecommitdiffstats
path: root/calendar/doc/C/Makefile.am
diff options
context:
space:
mode:
authorArturo Espinosa <unammx@src.gnome.org>1999-05-18 07:15:39 +0800
committerArturo Espinosa <unammx@src.gnome.org>1999-05-18 07:15:39 +0800
commit63472619b52678f869c710fdd353120e630c07b4 (patch)
treeea0d8978e28d3072eb1c655094e8076ce705fc4a /calendar/doc/C/Makefile.am
parentd609c57cba262bad9aa2f1096b241b1158bd7a86 (diff)
downloadgsoc2013-evolution-63472619b52678f869c710fdd353120e630c07b4.tar
gsoc2013-evolution-63472619b52678f869c710fdd353120e630c07b4.tar.gz
gsoc2013-evolution-63472619b52678f869c710fdd353120e630c07b4.tar.bz2
gsoc2013-evolution-63472619b52678f869c710fdd353120e630c07b4.tar.lz
gsoc2013-evolution-63472619b52678f869c710fdd353120e630c07b4.tar.xz
gsoc2013-evolution-63472619b52678f869c710fdd353120e630c07b4.tar.zst
gsoc2013-evolution-63472619b52678f869c710fdd353120e630c07b4.zip
Add Docbook framework for documenting Gnomecal -miguel
svn path=/trunk/; revision=928
Diffstat (limited to 'calendar/doc/C/Makefile.am')
-rw-r--r--calendar/doc/C/Makefile.am44
1 files changed, 44 insertions, 0 deletions
diff --git a/calendar/doc/C/Makefile.am b/calendar/doc/C/Makefile.am
new file mode 100644
index 0000000000..be6533d715
--- /dev/null
+++ b/calendar/doc/C/Makefile.am
@@ -0,0 +1,44 @@
+gnomecal_helpdir = $(datadir)/gnome/help/gnomecal/C
+
+gnomecal_help_DATA = \
+ gnomecal.html \
+ topic.dat
+
+SGML_FILES = \
+ gnomecal.sgml
+
+EXTRA_DIST = \
+ topic.dat \
+ $(SGML_FILES)
+
+all:
+
+gnomecal.html: gnomecal/gnomecal.html
+ -cp gnomecal/gnomecal.html .
+
+gnomecal/gnomecal.html: $(SGML_FILES)
+ -db2html gnomecal.sgml
+
+dist-hook:
+ mkdir $(distdir)/gnomecal
+ -cp gnomecal/*.html gnomecal/*.css $(distdir)/gnomecal
+ -cp gnomecal.html $(distdir)
+ mkdir $(distdir)/images
+ -cp images/*.gif images/*.jpg $(distdir)/images
+
+install-data-local: gnomecal.html
+ $(mkinstalldirs) $(gnomecal_helpdir)/images
+ -for file in $(srcdir)/gnomecal/*.html $(srcdir)/gnomecal/*.css; do \
+ basefile=`basename $$file`; \
+ $(INSTALL_DATA) $(srcdir)/$$file $(gnomecal_helpdir)/$$basefile; \
+ done
+ -for file in $(srcdir)/images/*.jpg $(srcdir)/images/*.gif; do \
+ $(INSTALL_DATA) $(srcdir)/$$file $(gnomecal_helpdir)/images;\
+ done
+
+gnomecal.ps: gnomecal.sgml
+ -db2ps $<
+
+gnomecal.rtf: gnomecal.sgml
+ -db2rtf $<
+