aboutsummaryrefslogtreecommitdiffstats
path: root/calendar/conduits/todo/Makefile.am
diff options
context:
space:
mode:
authorH.Habighorst <h.habighorst@googlemail.com>2009-10-01 11:37:50 +0800
committerMatthew Barnes <mbarnes@redhat.com>2009-10-01 11:37:50 +0800
commitf62728b55e201ea92e682e07b3253ce4fb42d5af (patch)
tree2083db9702cd5068e7fc4471c47086071e366015 /calendar/conduits/todo/Makefile.am
parentda3ae4fd5fa723abc4574d0459c761e76abba080 (diff)
downloadgsoc2013-evolution-f62728b55e201ea92e682e07b3253ce4fb42d5af.tar
gsoc2013-evolution-f62728b55e201ea92e682e07b3253ce4fb42d5af.tar.gz
gsoc2013-evolution-f62728b55e201ea92e682e07b3253ce4fb42d5af.tar.bz2
gsoc2013-evolution-f62728b55e201ea92e682e07b3253ce4fb42d5af.tar.lz
gsoc2013-evolution-f62728b55e201ea92e682e07b3253ce4fb42d5af.tar.xz
gsoc2013-evolution-f62728b55e201ea92e682e07b3253ce4fb42d5af.tar.zst
gsoc2013-evolution-f62728b55e201ea92e682e07b3253ce4fb42d5af.zip
Bug 596848 - Use per-target CPPFLAGS in automake files
Diffstat (limited to 'calendar/conduits/todo/Makefile.am')
-rw-r--r--calendar/conduits/todo/Makefile.am15
1 files changed, 7 insertions, 8 deletions
diff --git a/calendar/conduits/todo/Makefile.am b/calendar/conduits/todo/Makefile.am
index f17535f6de..782067a903 100644
--- a/calendar/conduits/todo/Makefile.am
+++ b/calendar/conduits/todo/Makefile.am
@@ -1,4 +1,8 @@
-AM_CPPFLAGS = \
+# ToDo Conduit
+privconduit_LTLIBRARIES = libetodo_conduit.la
+
+libetodo_conduit_la_CPPFLAGS = \
+ $(AM_CPPFLAGS) \
-I$(top_srcdir)/e-util \
-I$(top_builddir)/e-util \
-I$(top_srcdir)/widgets/misc \
@@ -7,11 +11,7 @@ AM_CPPFLAGS = \
-I$(top_builddir)/calendar/conduits/common \
$(EVOLUTION_CALENDAR_CONDUIT_CFLAGS)
-# ToDo Conduit
-privconduit_LTLIBRARIES = libetodo_conduit.la
-
-libetodo_conduit_la_SOURCES = \
- todo-conduit.c
+libetodo_conduit_la_SOURCES = todo-conduit.c
libetodo_conduit_la_LDFLAGS = -module -avoid-version $(NO_UNDEFINED)
@@ -34,8 +34,7 @@ conduit_DATA = e-todo.conduit
BUILT_SOURCES = $(conduit_DATA)
CLEANFILES = $(BUILT_SOURCES)
-EXTRA_DIST = \
- e-todo.conduit.in
+EXTRA_DIST = e-todo.conduit.in
dist-hook:
cd $(distdir); rm -f $(BUILT_SOURCES)