aboutsummaryrefslogtreecommitdiffstats
path: root/addressbook/gui/widgets/Makefile.am
diff options
context:
space:
mode:
authorChristopher James Lahey <clahey@helixcode.com>2000-04-10 23:46:25 +0800
committerChris Lahey <clahey@src.gnome.org>2000-04-10 23:46:25 +0800
commit99700ad43dcbf0bf95b335a9fc8f95934080d63c (patch)
treed325feef8319087bb323f592da432884d03b6e92 /addressbook/gui/widgets/Makefile.am
parentc4f6086c2948f3384dd95393f7ea737db6143682 (diff)
downloadgsoc2013-evolution-99700ad43dcbf0bf95b335a9fc8f95934080d63c.tar
gsoc2013-evolution-99700ad43dcbf0bf95b335a9fc8f95934080d63c.tar.gz
gsoc2013-evolution-99700ad43dcbf0bf95b335a9fc8f95934080d63c.tar.bz2
gsoc2013-evolution-99700ad43dcbf0bf95b335a9fc8f95934080d63c.tar.lz
gsoc2013-evolution-99700ad43dcbf0bf95b335a9fc8f95934080d63c.tar.xz
gsoc2013-evolution-99700ad43dcbf0bf95b335a9fc8f95934080d63c.tar.zst
gsoc2013-evolution-99700ad43dcbf0bf95b335a9fc8f95934080d63c.zip
Fixed a bug where I was sending the wrong information to some callbacks.
2000-04-10 Christopher James Lahey <clahey@helixcode.com> * addressbook/backend/ebook/e-book-view.c: Fixed a bug where I was sending the wrong information to some callbacks. * addressbook/backend/ebook/e-card.c, addressbook/backend/ebook/e-card.h: Added an e_card_duplicate function. Made ids get stored in vcards. Made sure to delete the url if it exists. * addressbook/backend/pas/Makefile.am: Made pas include addressbook/backend/ebook/ in the search path. * addressbook/backend/pas/pas-backend-file.c: Fixed some bugs and made the create card function store the generated id in the card being saved. * addressbook/backend/pas/pas-book-view.c: Fixed a double free bug. * addressbook/contact-editor/e-contact-editor.c: Fixed some bugs. Made the contact editor actually return a valid card when gtk_object_get(editor, "card", ...) is called. * addressbook/contact-editor/e-contact-editor.h: Fixed a copy and paste error. * addressbook/gui/component/addressbook.c: Made this get the card properly. * addressbook/gui/minicard/Makefile.am: Made this include contact-editor directory in the search path and link against libecontacteditor so that double clicking can open a dialog. * addressbook/gui/minicard/e-minicard.c: Fixed some small bugs. Made double clicking open a contact editor dialog if this minicard is contained in a minicard view. (It needs the minicard view to get the EBook to save to. * wombat/Makefile.am: Link wombat against libebook, since pas-backend-file now uses ECard. svn path=/trunk/; revision=2360
Diffstat (limited to 'addressbook/gui/widgets/Makefile.am')
-rw-r--r--addressbook/gui/widgets/Makefile.am4
1 files changed, 4 insertions, 0 deletions
diff --git a/addressbook/gui/widgets/Makefile.am b/addressbook/gui/widgets/Makefile.am
index 3534e9cb69..2eeb1ec3bc 100644
--- a/addressbook/gui/widgets/Makefile.am
+++ b/addressbook/gui/widgets/Makefile.am
@@ -1,5 +1,6 @@
INCLUDES = \
-I$(top_srcdir)/addressbook/backend/ebook \
+ -I$(top_srcdir)/addressbook/contact-editor \
-I$(top_srcdir)/widgets/e-text \
-I$(top_srcdir)/e-util \
$(GNOME_INCLUDEDIR)
@@ -47,6 +48,7 @@ minicard_test_LDADD = \
$(top_builddir)/e-util/libeutil.la \
$(top_builddir)/addressbook/backend/ebook/libebook.la \
$(top_builddir)/libversit/libversit.la \
+ $(top_builddir)/addressbook/contact-editor/libecontacteditor.a \
$(top_builddir)/widgets/e-text/libetext.a
reflow_test_SOURCES = \
@@ -60,6 +62,7 @@ reflow_test_LDADD = \
$(top_builddir)/e-util/libeutil.la \
$(top_builddir)/addressbook/backend/ebook/libebook.la \
$(top_builddir)/libversit/libversit.la \
+ $(top_builddir)/addressbook/contact-editor/libecontacteditor.a \
$(top_builddir)/widgets/e-text/libetext.a
minicard_view_test_SOURCES = \
@@ -73,4 +76,5 @@ minicard_view_test_LDADD = \
$(top_builddir)/e-util/libeutil.la \
$(top_builddir)/addressbook/backend/ebook/libebook.la \
$(top_builddir)/libversit/libversit.la \
+ $(top_builddir)/addressbook/contact-editor/libecontacteditor.a \
$(top_builddir)/widgets/e-text/libetext.a