aboutsummaryrefslogtreecommitdiffstats
path: root/addressbook/gui/widgets/Makefile.am
diff options
context:
space:
mode:
authorChristopher James Lahey <clahey@ximian.com>2001-06-09 14:31:55 +0800
committerChris Lahey <clahey@src.gnome.org>2001-06-09 14:31:55 +0800
commit5c58686c8ef72be5ed8a2d4469b3556f80d4b81c (patch)
tree0f708cfe4db04dad2e15a4bb44aa58772aaf3b21 /addressbook/gui/widgets/Makefile.am
parent7343d66ba7149b389b86508d188bab9c4bfe28dc (diff)
downloadgsoc2013-evolution-5c58686c8ef72be5ed8a2d4469b3556f80d4b81c.tar
gsoc2013-evolution-5c58686c8ef72be5ed8a2d4469b3556f80d4b81c.tar.gz
gsoc2013-evolution-5c58686c8ef72be5ed8a2d4469b3556f80d4b81c.tar.bz2
gsoc2013-evolution-5c58686c8ef72be5ed8a2d4469b3556f80d4b81c.tar.lz
gsoc2013-evolution-5c58686c8ef72be5ed8a2d4469b3556f80d4b81c.tar.xz
gsoc2013-evolution-5c58686c8ef72be5ed8a2d4469b3556f80d4b81c.tar.zst
gsoc2013-evolution-5c58686c8ef72be5ed8a2d4469b3556f80d4b81c.zip
Null terminate the strv here. (e_card_locate_match): ref here instead of
2001-06-09 Christopher James Lahey <clahey@ximian.com> * backend/ebook/e-card-compare.c (use_common_book_cb): Null terminate the strv here. (e_card_locate_match): ref here instead of unref. * backend/ebook/e-card-simple.c (e_card_simple_get): Handle a NULL card here. * contact-editor/Makefile.am (INCLUDES), gui/widgets/Makefile.am (INCLUDES): Added addressbook/gui/merging here. * contact-editor/e-contact-quick-add.c (book_ready_cb), gui/component/addressbook-component.c (dnd_drop_book_open_cb), gui/widgets/e-addressbook-table-adapter.c (addressbook_append_row), gui/widgets/e-addressbook-util.c (add_card_cb), gui/widgets/e-addressbook-view.c (selection_received), gui/widgets/e-minicard-control.c (book_open_cb): Use e_card_merging_book_add_card instead of e_book_add_card here. * gui/Makefile.am (SUBDIRS): Added merging. * gui/component/Makefile.am (evolution_addressbook_LDADD), gui/widgets/Makefile.am (minicard_test_LDADD, minicard_widget_test_LDADD): Added libecardmerging.a here. * gui/merging/, gui/merging/.cvsignore, gui/merging/Makefile.am: New addressbook library. * gui/merging/e-card-duplicate-detected.glade: Glade file for duplicate detected dialog. * gui/merging/e-card-merging.c, gui/merging/e-card-merging.h: New files for detecting duplicates before adding and putting up a dialog if duplicates are found. * gui/widgets/e-minicard-view.c: Include e-addressbook-util.h here. svn path=/trunk/; revision=10170
Diffstat (limited to 'addressbook/gui/widgets/Makefile.am')
-rw-r--r--addressbook/gui/widgets/Makefile.am10
1 files changed, 5 insertions, 5 deletions
diff --git a/addressbook/gui/widgets/Makefile.am b/addressbook/gui/widgets/Makefile.am
index 92b925d199..a375965a66 100644
--- a/addressbook/gui/widgets/Makefile.am
+++ b/addressbook/gui/widgets/Makefile.am
@@ -5,10 +5,7 @@ INCLUDES = \
-I$(top_srcdir) \
-I$(top_srcdir)/addressbook/backend/ebook \
-I$(top_srcdir)/addressbook/contact-editor \
- -I$(top_srcdir)/widgets/e-text \
- -I$(top_srcdir)/widgets/e-table \
- -I$(top_srcdir)/widgets/e-reflow \
- -I$(top_srcdir)/widgets/e-table \
+ -I$(top_srcdir)/addressbook/gui/merging \
-I$(top_srcdir)/widgets/misc \
$(BONOBO_GNOME_CFLAGS) \
$(EXTRA_GNOME_CFLAGS)
@@ -71,11 +68,13 @@ minicard_test_LDADD = \
$(top_builddir)/e-util/ename/libename.la \
$(top_builddir)/addressbook/contact-editor/libecontacteditor.a \
$(top_builddir)/addressbook/printing/libecontactprint.a \
+ $(top_builddir)/addressbook/gui/merging/libecardmerging.a \
$(top_builddir)/widgets/misc/libemiscwidgets.a \
$(top_builddir)/e-util/libeutil.la \
$(EXTRA_GNOME_LIBS) \
$(BONOBO_GNOME_LIBS) \
- $(GNOME_PRINT_LIBS)
+ $(GNOME_PRINT_LIBS) \
+ libeminicard.a
#reflow_test_SOURCES = \
# test-reflow.c
@@ -123,6 +122,7 @@ minicard_widget_test_LDADD = \
$(top_builddir)/addressbook/printing/libecontactprint.a \
$(top_builddir)/widgets/misc/libemiscwidgets.a \
$(top_builddir)/e-util/libeutil.la \
+ $(top_builddir)/addressbook/gui/merging/libecardmerging.a \
$(EXTRA_GNOME_LIBS) \
$(BONOBO_GNOME_LIBS) \
$(GNOME_PRINT_LIBS)