aboutsummaryrefslogtreecommitdiffstats
path: root/addressbook/gui/component/Makefile.am
diff options
context:
space:
mode:
authorEttore Perazzoli <ettore@src.gnome.org>2003-01-23 04:06:06 +0800
committerEttore Perazzoli <ettore@src.gnome.org>2003-01-23 04:06:06 +0800
commite8c9adced819e25b2b77314c773428c01a38643a (patch)
tree1eee6ce45b29ea7613f083df14b1ace58ad5a242 /addressbook/gui/component/Makefile.am
parent05114bc4955e1f49386a210b863af4ac230dab6e (diff)
downloadgsoc2013-evolution-e8c9adced819e25b2b77314c773428c01a38643a.tar
gsoc2013-evolution-e8c9adced819e25b2b77314c773428c01a38643a.tar.gz
gsoc2013-evolution-e8c9adced819e25b2b77314c773428c01a38643a.tar.bz2
gsoc2013-evolution-e8c9adced819e25b2b77314c773428c01a38643a.tar.lz
gsoc2013-evolution-e8c9adced819e25b2b77314c773428c01a38643a.tar.xz
gsoc2013-evolution-e8c9adced819e25b2b77314c773428c01a38643a.tar.zst
gsoc2013-evolution-e8c9adced819e25b2b77314c773428c01a38643a.zip
Version using $(BASE_VERSION). (etspecdir): Likewise. (iconsdir):
* gui/component/select-names/Makefile.am (gladedir): Version using $(BASE_VERSION). (etspecdir): Likewise. (iconsdir): Likewise. * gui/contact-list-editor/Makefile.am (iconsdir): Version using $(BASE_VERSION). (gladedir): Likewise. * gui/merging/Makefile.am (gladedir): Version using $(BASE_VERSION). * gui/search/Makefile.am (ruledir): Version using $(BASE_VERSION). * gui/component/Makefile.am (INCLUDES): Update EVOLUTION_IMAGESDIR to be versioned through $(BASE_VERSION). * gui/widgets/e-addressbook-view.c (init_collection): Use EVOLUTION_GALVIEWSDIR. * gui/widgets/Makefile.am (INCLUDES): Define EVOLUTION_GALVIEWSDIR and update EVOLUTION_IMAGESDIR. svn path=/trunk/; revision=19551
Diffstat (limited to 'addressbook/gui/component/Makefile.am')
-rw-r--r--addressbook/gui/component/Makefile.am63
1 files changed, 32 insertions, 31 deletions
diff --git a/addressbook/gui/component/Makefile.am b/addressbook/gui/component/Makefile.am
index 16eb925fe3..b1f585db7a 100644
--- a/addressbook/gui/component/Makefile.am
+++ b/addressbook/gui/component/Makefile.am
@@ -1,34 +1,35 @@
SUBDIRS = select-names
-INCLUDES = \
- -DG_LOG_DOMAIN=\"evolution-addressbook\" \
- -DPREFIX=\"$(prefix)\" \
- -DSYSCONFDIR=\"$(sysconfdir)\" \
- -DDATADIR=\"$(datadir)\" \
- -DLIBDIR=\"$(libdir)\" \
- -I$(top_srcdir) \
- -I$(top_builddir) \
- -I$(top_srcdir)/shell \
- -I$(top_builddir)/shell \
- -I$(top_srcdir)/widgets/misc \
- -I$(top_srcdir)/addressbook/gui/contact-editor \
- -I$(top_srcdir)/addressbook/gui/contact-list-editor \
- -I$(top_srcdir)/addressbook/gui/minicard \
- -I$(top_srcdir)/addressbook/gui/widgets \
- -I$(top_srcdir)/addressbook/backend \
- -I$(top_builddir)/addressbook/backend \
- -DEVOLUTION_DATADIR=\""$(datadir)"\" \
- -DEVOLUTION_GLADEDIR=\""$(gladedir)"\" \
- -DEVOLUTION_ETSPECDIR=\""$(etspecdir)"\" \
- -DEVOLUTION_ICONSDIR=\""$(iconsdir)"\" \
- -DEVOLUTION_LOCALEDIR=\""$(localedir)"\" \
- -DCAMEL_PROVIDERDIR=\""$(providerdir)"\" \
- -DEVOLUTION_IMAGESDIR=\""$(datadir)"/evolution/images\" \
- $(LDAP_CFLAGS) \
- -DG_DISABLE_DEPRECATED \
- -DGTK_DISABLE_DEPRECATED \
- -DLIBGNOME_DISABLE_DEPRECATED \
- -DLIBGNOMEUI_DISABLE_DEPRECATED \
+INCLUDES = \
+ -DG_LOG_DOMAIN=\"evolution-addressbook\" \
+ -DPREFIX=\"$(prefix)\" \
+ -DSYSCONFDIR=\"$(sysconfdir)\" \
+ -DDATADIR=\"$(datadir)\" \
+ -DLIBDIR=\"$(libdir)\" \
+ -I$(top_srcdir) \
+ -I$(top_builddir) \
+ -I$(top_srcdir)/shell \
+ -I$(top_builddir)/shell \
+ -I$(top_srcdir)/widgets/misc \
+ -I$(top_srcdir)/addressbook/gui/contact-editor \
+ -I$(top_srcdir)/addressbook/gui/contact-list-editor \
+ -I$(top_srcdir)/addressbook/gui/minicard \
+ -I$(top_srcdir)/addressbook/gui/widgets \
+ -I$(top_srcdir)/addressbook/backend \
+ -I$(top_builddir)/addressbook/backend \
+ -DEVOLUTION_DATADIR=\""$(datadir)"\" \
+ -DEVOLUTION_GLADEDIR=\""$(gladedir)"\" \
+ -DEVOLUTION_ETSPECDIR=\""$(etspecdir)"\" \
+ -DEVOLUTION_ICONSDIR=\""$(iconsdir)"\" \
+ -DEVOLUTION_LOCALEDIR=\""$(localedir)"\" \
+ -DCAMEL_PROVIDERDIR=\""$(providerdir)"\" \
+ -DEVOLUTION_IMAGESDIR=\""$(datadir)"/evolution-$(BASE_VERSION)/images\" \
+ -DEVOLUTION_UIDIR=\""$(evolutionuidir)"\" \
+ $(LDAP_CFLAGS) \
+ -DG_DISABLE_DEPRECATED \
+ -DGTK_DISABLE_DEPRECATED \
+ -DLIBGNOME_DISABLE_DEPRECATED \
+ -DLIBGNOMEUI_DISABLE_DEPRECATED \
$(EVOLUTION_ADDRESSBOOK_CFLAGS)
componentdir = $(COMPONENT_DIR)
@@ -95,10 +96,10 @@ $(server_in_files:.server.in.in=.server.in): $(server_in_files)
@INTLTOOL_SERVER_RULE@
-gladedir = $(datadir)/evolution/glade
+gladedir = $(datadir)/evolution-$(BASE_VERSION)/glade
glade_DATA = ldap-config.glade
-iconsdir = $(datadir)/evolution/images
+iconsdir = $(datadir)/evolution-$(BASE_VERSION)/images
EXTRA_DIST = \
$(glade_DATA) \