aboutsummaryrefslogtreecommitdiffstats
path: root/addressbook/gui/component/Makefile.am
diff options
context:
space:
mode:
authorChris Toshok <toshok@ximian.com>2004-04-15 10:14:35 +0800
committerChris Toshok <toshok@src.gnome.org>2004-04-15 10:14:35 +0800
commitc66ce91f684e02545b6d930c228d9239066f4c0f (patch)
tree51afdd6817293ee707f6bf78dd95944cf8815682 /addressbook/gui/component/Makefile.am
parent4481a42959da65cca4247184d0bf8ae27a57c0c7 (diff)
downloadgsoc2013-evolution-c66ce91f684e02545b6d930c228d9239066f4c0f.tar
gsoc2013-evolution-c66ce91f684e02545b6d930c228d9239066f4c0f.tar.gz
gsoc2013-evolution-c66ce91f684e02545b6d930c228d9239066f4c0f.tar.bz2
gsoc2013-evolution-c66ce91f684e02545b6d930c228d9239066f4c0f.tar.lz
gsoc2013-evolution-c66ce91f684e02545b6d930c228d9239066f4c0f.tar.xz
gsoc2013-evolution-c66ce91f684e02545b6d930c228d9239066f4c0f.tar.zst
gsoc2013-evolution-c66ce91f684e02545b6d930c228d9239066f4c0f.zip
rip out tons of functions - they all live in addressbook-view.c now. the
2004-04-14 Chris Toshok <toshok@ximian.com> * gui/component/addressbook.c: rip out tons of functions - they all live in addressbook-view.c now. the only thing left in this file is the addressbook_load* calls that do authentication. * gui/component/addressbook.h: remove prototypes for addressbook_new_control and addressbook_load_uri (it was #if 0'ed anyway.) * gui/component/addressbook-component.h: remove prototypes for _peek_activity_handler and _peek_source_list. * gui/component/addressbook-component.c: rip out tons of functions - they all live in addressbook-view.c now. (impl_createControls): simplify this immensely. we just create an AddressbookView and get the various widgets/controls from it. (impl_requestCreateItem): this function loses slightly - it needs per-window info (the selected source) but there's no way to get it. So we load the default book. Also, this uses a synchronous e_book call to load the book, which is not good. (addressbook_component_peek_source_list): nuke, not used by anything anyway. (addressbook_component_peek_activity_handler): nuked, not used by anything - and it's per-window anyway. * gui/component/Makefile.am (libevolution_addressbook_la_SOURCES): add addressbook-view.[ch]. * gui/component/addressbook-view.[ch]: rip out all of the per window stuff from addressbook.[ch] and addressbook-component.[ch] and put it here. svn path=/trunk/; revision=25471
Diffstat (limited to 'addressbook/gui/component/Makefile.am')
-rw-r--r--addressbook/gui/component/Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/addressbook/gui/component/Makefile.am b/addressbook/gui/component/Makefile.am
index 5bd4d381e4..48f27f96c8 100644
--- a/addressbook/gui/component/Makefile.am
+++ b/addressbook/gui/component/Makefile.am
@@ -35,6 +35,8 @@ libevolution_addressbook_la_SOURCES = \
autocompletion-config.h \
addressbook.c \
addressbook.h \
+ addressbook-view.c \
+ addressbook-view.h \
component-factory.c
# $(top_builddir)/addressbook/printing/libecontactprint.la