aboutsummaryrefslogtreecommitdiffstats
path: root/addressbook/gui/component/Makefile.am
diff options
context:
space:
mode:
authorJP Rosevear <jpr@ximian.com>2003-10-31 21:28:44 +0800
committerJP Rosevear <jpr@src.gnome.org>2003-10-31 21:28:44 +0800
commitbdf19d320404cc3c0aa6900ea711279f80ceab6a (patch)
tree344bc87daad354aa5ae91ce9e2b9a018d137d7a8 /addressbook/gui/component/Makefile.am
parent318ff6a39433c962150b5bd78e2bd13de7b637d8 (diff)
downloadgsoc2013-evolution-bdf19d320404cc3c0aa6900ea711279f80ceab6a.tar
gsoc2013-evolution-bdf19d320404cc3c0aa6900ea711279f80ceab6a.tar.gz
gsoc2013-evolution-bdf19d320404cc3c0aa6900ea711279f80ceab6a.tar.bz2
gsoc2013-evolution-bdf19d320404cc3c0aa6900ea711279f80ceab6a.tar.lz
gsoc2013-evolution-bdf19d320404cc3c0aa6900ea711279f80ceab6a.tar.xz
gsoc2013-evolution-bdf19d320404cc3c0aa6900ea711279f80ceab6a.tar.zst
gsoc2013-evolution-bdf19d320404cc3c0aa6900ea711279f80ceab6a.zip
set up vars and rules for versioning the .server files
2003-10-31 JP Rosevear <jpr@ximian.com> * configure.in: set up vars and rules for versioning the .server files * Makefile.am's: use rules for versioning .server file, ensure built files are removed before disting svn path=/trunk/; revision=23149
Diffstat (limited to 'addressbook/gui/component/Makefile.am')
-rw-r--r--addressbook/gui/component/Makefile.am11
1 files changed, 6 insertions, 5 deletions
diff --git a/addressbook/gui/component/Makefile.am b/addressbook/gui/component/Makefile.am
index 0e16c5ac92..458e8edbd7 100644
--- a/addressbook/gui/component/Makefile.am
+++ b/addressbook/gui/component/Makefile.am
@@ -78,10 +78,9 @@ install-data-local:
fi
server_in_files = GNOME_Evolution_Addressbook.server.in.in
-server_DATA = $(server_in_files:.server.in.in=.server)
-%.server.in: %.server.in.in
- sed -e "s|\@COMPONENTDIR\@|$(componentdir)|" $< > $@
-
+server_DATA = $(server_in_files:.server.in.in=_$(BASE_VERSION).server)
+@EVO_SUBST_SERVER_RULE@
+@EVO_NAME_SERVER_RULE@
@INTLTOOL_SERVER_RULE@
glade_DATA = ldap-config.glade
@@ -92,9 +91,11 @@ CLEANFILES = $(BUILT_SOURCES)
EXTRA_DIST = \
$(glade_DATA) \
$(schema_DATA) \
- $(server_DATA) \
$(server_in_files)
+dist-hook:
+ cd $(distdir); rm -f $(BUILT_SOURCES)
+
if ENABLE_PURIFY
PLINK = $(LIBTOOL) --mode=link $(PURIFY) $(CCLD) $(AM_CFLAGS) $(CFLAGS) $(LDFLAGS) -o $@