aboutsummaryrefslogtreecommitdiffstats
path: root/addressbook/gui/component/Makefile.am
diff options
context:
space:
mode:
authorChris Toshok <toshok@ximian.com>2002-04-19 05:26:48 +0800
committerChris Toshok <toshok@src.gnome.org>2002-04-19 05:26:48 +0800
commit9b7cc54d6ff67c83590706ee0b6749a7e1f3ca21 (patch)
tree3738f8f1fb02399157515420ff995ad5a428936f /addressbook/gui/component/Makefile.am
parent0c7e55e75cc787269ab570588f3873b6279aede1 (diff)
downloadgsoc2013-evolution-9b7cc54d6ff67c83590706ee0b6749a7e1f3ca21.tar
gsoc2013-evolution-9b7cc54d6ff67c83590706ee0b6749a7e1f3ca21.tar.gz
gsoc2013-evolution-9b7cc54d6ff67c83590706ee0b6749a7e1f3ca21.tar.bz2
gsoc2013-evolution-9b7cc54d6ff67c83590706ee0b6749a7e1f3ca21.tar.lz
gsoc2013-evolution-9b7cc54d6ff67c83590706ee0b6749a7e1f3ca21.tar.xz
gsoc2013-evolution-9b7cc54d6ff67c83590706ee0b6749a7e1f3ca21.tar.zst
gsoc2013-evolution-9b7cc54d6ff67c83590706ee0b6749a7e1f3ca21.zip
fix memory leaks.
2002-04-18 Chris Toshok <toshok@ximian.com> * backend/pas/pas-backend-ldap.c (get_ldap_library_info): fix memory leaks. * gui/component/GNOME_Evolution_Addressbook.oaf.in: remove the Addressbook_ConfigControl stuff to LDAP_ConfigControl. * gui/component/Makefile.am (evolution_addressbook_SOURCES): remove addressbook-config.* and add ldap-config.* (glade_DATA): same. (evolution_addressbook_LDADD): add LDAP_LIBS. * gui/component/addressbook-component.c (owner_set_cb): addressbook_config_register_factory => ldap_config_register_factory. * gui/component/addressbook.c (book_open_cb): remove source->type check - they're always LDAP. (load_uri_cb): same. * gui/component/addressbook-storage.c (ldap_unparse_ssl): new function. (ldap_parse_ssl): new function. (addressbook_storage_init_source_uri): use a more flexible scheme to build up the uri's, and add in the ssl parameter. (load_source_data): fill in source->ssl, and remove source->type assignment. (addressbook_source_copy): copy source->ssl, and remove source->type copy. (create_ldap_folder): addressbook_create_new_source => ldap_config_create_new_source. * gui/component/addressbook-storage.h: remove AddressbookSourceType (it was always LDAP), and add AddressbookLDAPSSLType. svn path=/trunk/; revision=16524
Diffstat (limited to 'addressbook/gui/component/Makefile.am')
-rw-r--r--addressbook/gui/component/Makefile.am18
1 files changed, 9 insertions, 9 deletions
diff --git a/addressbook/gui/component/Makefile.am b/addressbook/gui/component/Makefile.am
index 01e35b60d8..eb4de0d536 100644
--- a/addressbook/gui/component/Makefile.am
+++ b/addressbook/gui/component/Makefile.am
@@ -27,8 +27,6 @@ bin_PROGRAMS = \
evolution_addressbook_SOURCES = \
addressbook-component.c \
addressbook-component.h \
- addressbook-config.c \
- addressbook-config.h \
addressbook-factory.c \
addressbook-storage.c \
addressbook-storage.h \
@@ -39,7 +37,9 @@ evolution_addressbook_SOURCES = \
e-address-widget.h \
e-address-widget.c \
e-address-popup.h \
- e-address-popup.c
+ e-address-popup.c \
+ ldap-config.c \
+ ldap-config.h
evolution_addressbook_LDADD = \
select-names/libeselectnames.la \
@@ -59,7 +59,7 @@ evolution_addressbook_LDADD = \
$(top_builddir)/filter/libfilter.la \
$(top_builddir)/e-util/libeutil.la \
$(top_builddir)/widgets/menus/libmenus.la \
- $(EVOLUTION_ADDRESSBOOK_LIBS)
+ $(EVOLUTION_ADDRESSBOOK_LIBS) $(LDAP_LIBS)
evolution_addressbook_LDFLAGS = `gnome-config --libs gdk_pixbuf` -export-dynamic
@@ -70,14 +70,14 @@ oaf_in_files = GNOME_Evolution_Addressbook.oaf.in
oaf_DATA = $(oaf_in_files:.oaf.in=.oaf)
gladedir = $(datadir)/evolution/glade
-glade_DATA = addressbook-config.glade
+glade_DATA = ldap-config.glade
iconsdir = $(datadir)/images/evolution
-EXTRA_DIST = \
- $(glade_DATA) \
- $(oaf_DATA) \
- addressbook-config.glade \
+extra_dist = \
+ $(glade_data) \
+ $(oaf_data) \
+ ldap-config.glade \
$(oaf_in_files)
if ENABLE_PURIFY