aboutsummaryrefslogtreecommitdiffstats
path: root/addressbook/Makefile.am
diff options
context:
space:
mode:
authorJeffrey Stedfast <fejj@novell.com>2004-05-25 22:57:04 +0800
committerJeffrey Stedfast <fejj@src.gnome.org>2004-05-25 22:57:04 +0800
commit479e75883911fc03b2b7d09d69f48faf0f3812eb (patch)
treee0fd0f15f7abaf56031e6be4262a2cc3aea74ba7 /addressbook/Makefile.am
parentf87fe83e1df3a2370b9b2dcef90eb8869f4b0eff (diff)
downloadgsoc2013-evolution-479e75883911fc03b2b7d09d69f48faf0f3812eb.tar
gsoc2013-evolution-479e75883911fc03b2b7d09d69f48faf0f3812eb.tar.gz
gsoc2013-evolution-479e75883911fc03b2b7d09d69f48faf0f3812eb.tar.bz2
gsoc2013-evolution-479e75883911fc03b2b7d09d69f48faf0f3812eb.tar.lz
gsoc2013-evolution-479e75883911fc03b2b7d09d69f48faf0f3812eb.tar.xz
gsoc2013-evolution-479e75883911fc03b2b7d09d69f48faf0f3812eb.tar.zst
gsoc2013-evolution-479e75883911fc03b2b7d09d69f48faf0f3812eb.zip
Generate the addressbook-errors.xml.h file and install the xml file and
2004-05-25 Jeffrey Stedfast <fejj@novell.com> * Makefile.am: Generate the addressbook-errors.xml.h file and install the xml file and all that jazz. * addressbook-errors.xml: New error xml file. * gui/widgets/e-addressbook-view.c (backend_died): Use e_error_run(). * gui/widgets/eab-gui-util.c (eab_error_dialog): Use e_error_run(). (eab_load_error_dialog): Same. (eab_search_result_dialog): Same. (eab_prompt_save_dialog): Same. (save_it): Same. * gui/contact-editor/e-contact-editor.c (categories_clicked): Use e_error_run(). (e_contact_editor_is_valid): Same. (save_contact): Same. * gui/component/addressbook-view.c (delete_addressbook_cb): Use e_error_run(). * gui/component/addressbook-config.c (addressbook_ldap_init): Use e_error_run(). (addressbook_ldap_auth): Same. (addressbook_root_dse_query): Same. (do_ldap_root_dse_query): Same. (do_schema_query): Same. svn path=/trunk/; revision=26077
Diffstat (limited to 'addressbook/Makefile.am')
-rw-r--r--addressbook/Makefile.am18
1 files changed, 16 insertions, 2 deletions
diff --git a/addressbook/Makefile.am b/addressbook/Makefile.am
index d307057f02..4fde08a4a9 100644
--- a/addressbook/Makefile.am
+++ b/addressbook/Makefile.am
@@ -5,5 +5,19 @@ endif
SUBDIRS = \
util printing gui importers tools $(CONDUIT_SUBDIR)
-EXTRA_DIST = \
- ChangeLog.pre-1-4
+error_DATA = addressbook-errors.xml
+error_i18n = $(error_DATA:.xml=.xml.h)
+errordir = $(privdatadir)/errors
+%.xml.h: %.xml
+ $(top_builddir)/e-util/e-error-tool $^
+
+EXTRA_DIST = \
+ ChangeLog.pre-1-4 \
+ $(error_DATA)
+
+dist-hook:
+ cd $(distdir); rm -f $(BUILT_SOURCES)
+
+BUILT_SOURCES = $(error_i18n)
+
+CLEANFILES = $(BUILT_SOURCES)