aboutsummaryrefslogtreecommitdiffstats
path: root/lib/egg/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'lib/egg/Makefile.am')
-rw-r--r--lib/egg/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/lib/egg/Makefile.am b/lib/egg/Makefile.am
index 5fd72a051..ae1d23c8d 100644
--- a/lib/egg/Makefile.am
+++ b/lib/egg/Makefile.am
@@ -67,7 +67,7 @@ stamp-eggtypebuiltins.c: $(EGGHEADERS)
--vhead "GType\n@enum_name@_get_type (void)\n{\n" \
--vhead " static GType type = 0;\n\n" \
--vhead " if (G_UNLIKELY (type == 0))\n {\n" \
- --vhead " const G@Type@Value _@enum_name@_values[] = {" \
+ --vhead " static const G@Type@Value _@enum_name@_values[] = {" \
--vprod " { @VALUENAME@, \"@VALUENAME@\", \"@valuenick@\" }," \
--vtail " { 0, NULL, NULL }\n };\n\n" \
--vtail " type = g_@type@_register_static (\"@EnumName@\", _@enum_name@_values);\n }\n\n" \