aboutsummaryrefslogtreecommitdiffstats
path: root/lib/egg/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'lib/egg/Makefile.am')
-rw-r--r--lib/egg/Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/lib/egg/Makefile.am b/lib/egg/Makefile.am
index e2d678bb7..a399d3c7c 100644
--- a/lib/egg/Makefile.am
+++ b/lib/egg/Makefile.am
@@ -54,13 +54,13 @@ noinst_HEADERS = \
eggmarshalers.h \
eggintl.h
-eggmarshalers.h:
+eggmarshalers.h: eggmarshalers.list
cd $(srcdir) \
&& $(GLIB_GENMARSHAL) --prefix=_egg_marshal eggmarshalers.list --header > xgen-emh \
&& cp xgen-emh eggmarshalers.h \
&& rm -f xgen-emh xgen-emh~
-eggmarshalers.c:
+eggmarshalers.c: eggmarshalers.list
cd $(srcdir) \
&& $(GLIB_GENMARSHAL) --prefix=_egg_marshal eggmarshalers.list --body > xgen-emc \
&& cp xgen-emc eggmarshalers.c \