aboutsummaryrefslogtreecommitdiffstats
path: root/lib/egg/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'lib/egg/Makefile.am')
-rw-r--r--lib/egg/Makefile.am13
1 files changed, 3 insertions, 10 deletions
diff --git a/lib/egg/Makefile.am b/lib/egg/Makefile.am
index 77b7c0eaa..4920ffbba 100644
--- a/lib/egg/Makefile.am
+++ b/lib/egg/Makefile.am
@@ -1,4 +1,5 @@
INCLUDES = \
+ -I$(top_builddir)/lib/egg \
$(EPIPHANY_DEPENDENCY_CFLAGS) \
-DCURSOR_DIR=\"$(pkgdatadir)/art\" \
-DGTK_DISABLE_DEPRECATED \
@@ -37,18 +38,10 @@ noinst_HEADERS = \
BUILT_SOURCES = eggmarshalers.h eggmarshalers.c
eggmarshalers.h: eggmarshalers.list
- cd $(srcdir) \
- && $(GLIB_GENMARSHAL) --prefix=_egg_marshal eggmarshalers.list --header > xgen-emh \
- && cp xgen-emh eggmarshalers.h \
- && rm -f xgen-emh xgen-emh~
+ $(GLIB_GENMARSHAL) --prefix=_egg_marshal $(srcdir)/eggmarshalers.list --header > eggmarshalers.h
eggmarshalers.c: eggmarshalers.list
- cd $(srcdir) \
- && $(GLIB_GENMARSHAL) --prefix=_egg_marshal eggmarshalers.list --body > xgen-emc \
- && cp xgen-emc eggmarshalers.c \
- && rm -f xgen-emc xgen-emc~
-
-egg-marshal.c: eggmarshalers.h eggmarshalers.c
+ $(GLIB_GENMARSHAL) --prefix=_egg_marshal $(srcdir)/eggmarshalers.list --body > eggmarshalers.c
EXTRA_DIST= \
eggmarshalers.list