aboutsummaryrefslogtreecommitdiffstats
path: root/lib/egg/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'lib/egg/Makefile.am')
-rw-r--r--lib/egg/Makefile.am4
1 files changed, 4 insertions, 0 deletions
diff --git a/lib/egg/Makefile.am b/lib/egg/Makefile.am
index 09de92ac5..7d2471e68 100644
--- a/lib/egg/Makefile.am
+++ b/lib/egg/Makefile.am
@@ -8,6 +8,7 @@ INCLUDES = \
noinst_LTLIBRARIES = libegg.la
EGGSOURCES = \
+ eggdropdowntoolbutton.c \
eggtreemultidnd.c \
egg-editable-toolbar.c \
egg-toolbars-model.c \
@@ -21,6 +22,7 @@ libegg_la_SOURCES = \
eggmarshalers.c
EGGHEADERS = \
+ eggdropdowntoolbutton.h \
eggtreemultidnd.h \
egg-editable-toolbar.h \
egg-toolbars-model.h \
@@ -34,6 +36,8 @@ noinst_HEADERS = \
eggmarshalers.h \
eggintl.h
+BUILT_SOURCES = eggmarshalers.h eggmarshalers.c
+
eggmarshalers.h: eggmarshalers.list
cd $(srcdir) \
&& $(GLIB_GENMARSHAL) --prefix=_egg_marshal eggmarshalers.list --header > xgen-emh \