aboutsummaryrefslogtreecommitdiffstats
path: root/lib/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'lib/Makefile.am')
-rw-r--r--lib/Makefile.am4
1 files changed, 4 insertions, 0 deletions
diff --git a/lib/Makefile.am b/lib/Makefile.am
index c3cd5a16d..eab56e942 100644
--- a/lib/Makefile.am
+++ b/lib/Makefile.am
@@ -133,6 +133,7 @@ ephy-lib-type-builtins.c: stamp-ephy-lib-type-builtins.c Makefile
@true
stamp-ephy-lib-type-builtins.c: Makefile $(TYPES_H_FILES)
$(GLIB_MKENUMS) \
+ --fhead "#include <config.h>\n\n" \
--fhead "#include \"ephy-lib-type-builtins.h\"\n\n" \
--fprod "\n/* enumerations from \"@filename@\" */" \
--fprod "\n#include \"@filename@\"" \
@@ -153,6 +154,9 @@ ephy-lib-type-builtins.h: stamp-ephy-lib-type-builtins.h Makefile
@true
stamp-ephy-lib-type-builtins.h: Makefile $(TYPES_H_FILES)
$(GLIB_MKENUMS) \
+ --fhead "#if !defined (__EPHY_EPIPHANY_H_INSIDE__) && !defined (EPIPHANY_COMPILATION)\n" \
+ --fhead "#error Only <epiphany/epiphany.h> can be included directly.\n" \
+ --fhead "#endif\n\n" \
--fhead "#ifndef EPHY_LIB_TYPE_BUILTINS_H\n" \
--fhead "#define EPHY_LIB_TYPE_BUILTINS_H 1\n\n" \
--fhead "#include <glib-object.h>\n\n" \