aboutsummaryrefslogtreecommitdiffstats
path: root/embed/web-extension/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'embed/web-extension/Makefile.am')
-rw-r--r--embed/web-extension/Makefile.am20
1 files changed, 20 insertions, 0 deletions
diff --git a/embed/web-extension/Makefile.am b/embed/web-extension/Makefile.am
new file mode 100644
index 000000000..fe7277288
--- /dev/null
+++ b/embed/web-extension/Makefile.am
@@ -0,0 +1,20 @@
+webextension_LTLIBRARIES = libephywebextension.la
+
+webextensiondir = \
+ $(libdir)/epiphany/$(EPIPHANY_MAJOR)/web-extensions
+
+libephywebextension_la_SOURCES = \
+ ephy-web-extension.c \
+ ephy-web-extension.h
+
+libephywebextension_la_CPPFLAG = \
+ $(AM_CPPFLAGS)
+
+libephywebextension_la_CFLAGS = \
+ $(WEB_EXTENSION_CFLAGS)
+
+libephywebextension_la_LIBADD = \
+ $(WEB_EXTENSION_LIBS)
+
+libephywebextension_la_LDFLAGS = \
+ -module -avoid-version -no-undefined