aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac15
1 files changed, 15 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index c30027419..3bbbf53e4 100644
--- a/configure.ac
+++ b/configure.ac
@@ -344,6 +344,21 @@ dnl changed from nsIXULChromeRegistry in 1.8a4
AC_CHECK_FILE([$MOZILLA_INCLUDE_ROOT/chrome/nsIChromeRegistrySea.h],
[AC_DEFINE([HAVE_CHROME_NSICHROMEREGISTRYSEA_H], [1], [Define if nsIChromeRegistrySea.h exists])])
+dnl added after 1.7.3, on aviary and in 1.8a5 on trunk
+
+AC_MSG_CHECKING([for nsIDOMNSEvent::GetIsTrusted])
+
+AC_COMPILE_IFELSE(
+ [AC_LANG_PROGRAM(
+ [[#include <dom/nsIDOMNSEvent.h>]],
+ [[nsIDOMNSEvent *p;
+ p->GetIsTrusted (nsnull);]]
+ )],
+ [AC_DEFINE([MOZ_NSIDOMNSEVENT_GETISTRUSTED],[1],[dummy]) result=yes],
+ [result=no])
+
+AC_MSG_RESULT([$result])
+
dnl check for broken reload in GtkMozEmbed
dnl FIXME: I have NO IDEA how to do this. For now, just always enable our workaround
dnl