aboutsummaryrefslogtreecommitdiffstats
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorXan Lopez <xan@igalia.com>2012-12-12 00:29:19 +0800
committerXan Lopez <xan@igalia.com>2012-12-12 19:22:33 +0800
commit6ede0c3ebcbc129ea1112ee9f43427231ab50e07 (patch)
treea7914732e5ce2b86eeaf7d44956371c610d341e4 /tests/Makefile.am
parent7f6211d2901f70d571f18106bf97ff636712a712 (diff)
downloadgsoc2013-epiphany-6ede0c3ebcbc129ea1112ee9f43427231ab50e07.tar
gsoc2013-epiphany-6ede0c3ebcbc129ea1112ee9f43427231ab50e07.tar.gz
gsoc2013-epiphany-6ede0c3ebcbc129ea1112ee9f43427231ab50e07.tar.bz2
gsoc2013-epiphany-6ede0c3ebcbc129ea1112ee9f43427231ab50e07.tar.lz
gsoc2013-epiphany-6ede0c3ebcbc129ea1112ee9f43427231ab50e07.tar.xz
gsoc2013-epiphany-6ede0c3ebcbc129ea1112ee9f43427231ab50e07.tar.zst
gsoc2013-epiphany-6ede0c3ebcbc129ea1112ee9f43427231ab50e07.zip
Handle a bit more gracefully the self-launch detection
Check whether the app that will launch a given download is actually the browser itself, and do nothing *before* going ahead. Seems better than actually launching and then aborting on startup through UUID hacks.
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am12
1 files changed, 11 insertions, 1 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 992547eb7..aaaf6c149 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -4,6 +4,7 @@ noinst_PROGRAMS = \
test-ephy-bookmarks \
test-ephy-completion-model \
test-ephy-download \
+ test-ephy-embed-shell \
test-ephy-embed-single \
test-ephy-embed-utils \
test-ephy-encodings \
@@ -100,7 +101,8 @@ INCLUDES = \
-I$(top_srcdir)/src/bookmarks
CFLAGS = \
- $(DEPENDENCIES_CFLAGS) \
+ -DTEST_DIR=\"$(srcdir)\"\
+ $(DEPENDENCIES_CFLAGS) \
$(CODE_COVERAGE_CFLAGS) \
$(AM_CFLAGS)
@@ -125,6 +127,9 @@ test_ephy_completion_model_SOURCES = \
test_ephy_download_SOURCES = \
ephy-download-test.c
+test_ephy_embed_shell_SOURCES = \
+ ephy-embed-shell-test.c
+
test_ephy_embed_single_SOURCES = \
ephy-embed-single-test.c
@@ -173,3 +178,8 @@ test_ephy_web_app_utils_SOURCES = \
test_ephy_web_view_SOURCES = \
ephy-web-view-test.c
+
+EXTRA_DIST = \
+ data/test.html \
+ applications/epiphany.desktop \
+ applications/defaults.list