aboutsummaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorXan Lopez <xan@gnome.org>2007-07-28 04:27:56 +0800
committerXan Lopez <xan@src.gnome.org>2007-07-28 04:27:56 +0800
commitc75bf8633191306efc4120fd589d0c375f286e71 (patch)
treee573b99549ca95c38ef67c9dd5d53829cb545a30 /src/Makefile.am
parentec7067fd30fe1bd5d0b69a648359d8085328f398 (diff)
downloadgsoc2013-epiphany-c75bf8633191306efc4120fd589d0c375f286e71.tar
gsoc2013-epiphany-c75bf8633191306efc4120fd589d0c375f286e71.tar.gz
gsoc2013-epiphany-c75bf8633191306efc4120fd589d0c375f286e71.tar.bz2
gsoc2013-epiphany-c75bf8633191306efc4120fd589d0c375f286e71.tar.lz
gsoc2013-epiphany-c75bf8633191306efc4120fd589d0c375f286e71.tar.xz
gsoc2013-epiphany-c75bf8633191306efc4120fd589d0c375f286e71.tar.zst
gsoc2013-epiphany-c75bf8633191306efc4120fd589d0c375f286e71.zip
Add support for the WebKit engine, compile with --with-engine=webkit to
2007-07-27 Xan Lopez <xan@gnome.org> * Makefile.am: * configure.ac: * doc/reference/Makefile.am: * embed/Makefile.am: * embed/ephy-embed-factory.c: (ephy_embed_factory_new_object): * embed/ephy-embed-persist.c: * embed/ephy-embed-shell.c: * embed/ephy-embed.c: * embed/webkit/Makefile.am: * embed/webkit/webkit-embed-find.cpp: * embed/webkit/webkit-embed-find.h: * embed/webkit/webkit-embed-persist.cpp: * embed/webkit/webkit-embed-persist.h: * embed/webkit/webkit-embed-single.cpp: * embed/webkit/webkit-embed-single.h: * embed/webkit/webkit-embed.cpp: * embed/webkit/webkit-embed.h: * src/Makefile.am: Add support for the WebKit engine, compile with --with-engine=webkit to activate. * embed/mozilla/mozilla-embed-single.cpp: Move to the G_DEFINE_TYPE_WITH_CODE macro. svn path=/trunk/; revision=7208
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am38
1 files changed, 31 insertions, 7 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index ff3bdfdfb..214b813b5 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -153,14 +153,14 @@ libpyphany_la_CPPFLAGS = \
-I$(top_srcdir)/lib/widgets \
-I$(top_srcdir)/lib/egg \
-I$(top_srcdir)/embed \
- -I$(top_srcdir)/embed/mozilla \
+ -I$(top_srcdir)/embed/$(with_engine) \
-I$(top_srcdir)/src \
-I$(top_srcdir)/src/bookmarks \
-I$(top_builddir)/lib \
-I$(top_builddir)/lib/widgets \
-I$(top_builddir)/lib/egg \
-I$(top_builddir)/embed \
- -I$(top_builddir)/embed/mozilla \
+ -I$(top_builddir)/embed/$(with_engine) \
-I$(top_builddir)/src \
-I$(top_builddir)/src/bookmarks \
$(PYTHON_INCLUDES) \
@@ -203,20 +203,44 @@ epiphany_CFLAGS = \
$(DBUS_CFLAGS) \
$(AM_CFLAGS)
-epiphany_LDFLAGS = -R$(GECKO_HOME) -dlopen self
+epiphany_LDFLAGS = -dlopen self
epiphany_LDADD = \
libephymain.la \
$(top_builddir)/src/bookmarks/libephybookmarks.la \
- $(top_builddir)/embed/libephyembedfactory.la \
- $(top_builddir)/embed/mozilla/libephymozillaembed.la \
+ $(top_builddir)/embed/libephyembedfactory.la
+
+if WITH_GECKO_ENGINE
+epiphany_LDADD += \
+ $(top_builddir)/embed/mozilla/libephymozillaembed.la
+endif
+
+if WITH_WEBKIT_ENGINE
+epiphany_LDADD += \
+ $(top_builddir)/embed/webkit/libephywebkitembed.la
+endif
+
+epiphany_LDADD += \
$(top_builddir)/embed/libephyembed.la \
$(top_builddir)/lib/widgets/libephywidgets.la \
$(top_builddir)/lib/libephymisc.la \
- $(top_builddir)/lib/egg/libegg.la \
+ $(top_builddir)/lib/egg/libegg.la
+
+if WITH_GECKO_ENGINE
+epiphany_LDFLAGS += -R$(GECKO_HOME)
+
+epiphany_LDADD += \
$(GECKO_LIBS) \
$(GECKO_EXTRA_LIBS) \
- $(GECKO_GLUE_LIBS) \
+ $(GECKO_GLUE_LIBS)
+endif
+
+if WITH_WEBKIT_ENGINE
+epiphany_LDADD += \
+ $(WEBKIT_LIBS)
+endif
+
+epiphany_LDADD += \
$(DEPENDENCIES_LIBS) \
$(DBUS_LIBS) \
$(LIBINTL)